Taranis X9D, Pixhawk, radio fail safe, how to set up?

I have looked everywhere, but for some reason, can’t find step-by-step on how to set up a Taranis X9D and Pixhawk for radio fail safe…I have tried several different methods, and so far, none work.

Someone have a link or explanation?

Thanks so much.


Have you tried here http://copter.ardupilot.com/wiki/configuration/throttle-failsafe/

Sure have TC…didn’t help.

I know it should, and maybe I did something wrong, but it didn’t help.



I understand the principle or what needs to be done, but the Arducopter article uses a different radio than mine, I just don’t know what steps need done in what order, with the X9D.

What receiver are you using?

I have an L9R connected using the sbus out to the Pixhawk’s rc in and that’s enough for the radio side as the sbus protocol has it’s own way of detecting a radio loss and tells the Pixhawk it’s lost the rc link.
The rest is in the link TCIII posted, just follow the guide under “Set-up for No-Signal method”.


The receiver is an X8R.

I understand that there are two fail safe procedures that need to be covered, (besides low voltage from the flight battery)…of course please correct me if I am wrong:

  1. If the radio fails…the r/c receiver no longer gets a signal from the radio, and

  2. If the receiver fails…the Pixhawk no longer receives a signal from the receiver.

Now I suppose if #2 is taken care of, then #1 is also taken care of (but not the other way around.)…so if I can get #2 to work, I’m good to go.


In the video, the “No Signal Method” covers if the transmitter fails…how does that cover if the receiver fails?

Seems like there is something basic that perhaps I am not understanding.

As it stands now, no matter what I try, when I turn off the radio to test the failsafe, the Pixhawk does NOT got into RTL mode (I know because of course I am monitoring via USB or telemetry).

Thanks so much…


There is only the one radio failsafe which is loss of rc link. The other failure is a loss of power to the receiver which is totally separate.

I’m assuming you have the x8r failsafe set to no pulses on lost signal. With the transmitter off power up the receiver and briefly push the f/s button to do it.

Power up the tx and the pixhawk and connect it to mission planner. Go to the failsafe section and watch the number under radio 3, with throttle at minimum turn off the transmitter, the number should drop really low.

If the number doesn’t go any lower when you turn off the transmitter, you will need to re bind the taranis to your receiver but drop your throttle trim as low as it will go first, re bind, then put your throttle trim back to neutral. Shouldn’t need to do this step as it’s for low throttle rather than no pulse but it might help you.

Once you have the radio 3 number going lower on power off in the fs pwm box to the right enter the number you have for radio 3 when the transmitter is off +10 (so if you had 900, +10 = 910 so you enter 910 in the box).

To test it, you have to arm the pixhawk and move the throttle up (you can do all this with a usb connection and no battery) then turn off the transmitter and you should see the failsafe page (or the hud on the main screen) change to failsafe or land.


What do you mean by the second sentence?



You said there 2 failsafes to cover, that’s the 2nd one you mentioned and you don’t need to cover it under radio failsafe.

Radio failsafe is just the link from transmitter to receiver.

If the receiver fails it will be more likely due to a power failure on the UAV which 9 times out of 10 will result in a crash. If you are VERY lucky and VERY high and it’s just a brownout it may come back on line before you hit the deck.