Servers by jDrones

Taranis X9D+ and X8R receiver binding issue.

Hello,

I have updated a Taranis X9D+ with the latest firmware (2.3.5) I have also a X8R receiver.
After updating the firmware using software Companion, TX and RX don’t bind anymore.
I have tried to update the firmware for the internal and external module using the one provided by FRSKY: https://www.frsky-rc.com/x8r/.
For the internal and external Module I have tried both the combination LBT - LBT and FCC - FCC.
but no one works.

Any advice?

Good day, did you try flash again the firmware from the official website?

Make sure you have the same version (EU or non EU) on both your X8R and XJT.

Dear David and Igor,

I have solved the issue, I was using a wrong firmware for the internal module.
For those that will encounter the same problem using Taranis X9D+ and X8R receiver you have to use the following firmwares:

Copy both firmwares inside the SD card of your radio, these two link explain how.

Best regards.

1 Like

Thank you Marco, your procedure worked. I wish I came across your post a few day ago, it would of saved me a lot of time and aggravation. now onwards and upwards!

Servers by jDrones