Tandem Helicopter - Parameter settings

Hello.

I’m trying to fly a tandem with Mission Planner using Pixhawk 1.
However, when I connect Pixhawk 1 and look at the parameter list, the following parameters are not displayed.

H_SV1_POS
H_SV2_POS
H_SV3_POS
H_SV4_POS
H_SV5_POS
H_SV6_POS

Also, if you try to open a parameter file that contains the above parameters while Pixhawk is connected, the screen below will appear and you will not be able to open the file. (If I don’t have Pixhawk connected, I can open the file.)

Any suggestion, please?
Thanks.

Hi @Iwamoto
Did you load the Helicopter version of ArduCopter? What is the version that you loaded?

You can check the version of arducopter firmware by looking in the data tab of mission planner. Go to the bottom panel and you’ll see more tabs there. Select the Messages tab and look for the version of the arducopter firmware. Be sure that you are connected to your Pixhawk when you do this.

Did you set the frame class to heli_dual?

Hi.
Thanks for replying.

I load the Helicopter version of ArduCopter. The version that I loaded is “Copter V4.3.0 OFFICIAL”

Also I set the frame class to heli_dual.

But this problem was not resolved.

These parameters are not automatically displayed unless you choose the generic swash plate type for each of the swashplates. If you have one of the standard swashplates, then just use that option for the swashplate type.
You can find the swashplate types that are supported in the wiki.
https://ardupilot.org/copter/docs/traditional-helicopter-swashplate-setup.html