Tandem Frame - Missing parameters?

After some rework on my 250 tandem testbed, I went through the set-up videos that Chris has added to the wiki.

The 250 tandem is a flybar set-up but there does not appear to be an H_Flybar_Mode parameter. The H_Swash_Type parameter is also missing.

Firmware is Coptor V3.5.7(b11c6af3). Frame type is 11 - longitudinal.

Parameters are missing in Mission Planner, APMPlanner and QGroundControl.

Any suggestions?



Great to hear from you again and see that you are still working on your tandem. So the dual frame (frame type 11) was written for CCPM swashplates. This doesn’t have an H-1 swashplate option. It also doesn’t have the flybar option. Are your swashplates H-1 or CCPM? as for the flybar. Just set your P and D gains for pitch and roll to zero. Use the FF gain to set the proper rate as specified in the helicopter tuning wiki. There may be some tandem unique things you will need to do in tuning your heli. In tuning the pitch axis, you will have two ways to adjust the control throw, pitch_FF gain and DCP_SCALAR. So I’m not sure how to tell you to tune these. You are treading on new ground.


Thanks for the quick reply. The swash set up is CCPM and it is working so no problems there.

I have set up the parameters for flybar as per the wiki. Just wanted to check that he lack of the selection parameter was not a “finger problem” on my end.

I made some modification to the tandem gear train and redid the mechanical set-up. Much happier with it now as starting point for tuning. If the weather holds I may get some flights in this week before work takes me offshore again.

I will report back after the next flights.