Takoff mode plane 4.0.5

Hi. I’m trying to takeoff in new takeoff mode. After little shaking plane motors spinning well, but when I switch to Auto mode, to tell plane to start mission, motor stops.
Who can help?

You need to elaborate on your problem.

Always provide details such as;

  1. What type of plane, how many motors?
  2. What FC?
  3. Some pics also helps.

right now we can think you were flying a 747 plane :slight_smile: kidding…

:slight_smile: My plane is X-Uav Talon, cuav pixhack v3x with arduplane firmware v4.0.5.
I wrote simple mission without takeoff, and tried to fly in takeoff mode, I set the TKOFF_THR_MINACC to 0, and when plane started motor, and wanted to fly, I switched it to auto mode, to fly with waypoints, but after switching in auto mode, motors stops spinning.

Well, you did not let it take off… Shaking is not flying.

1 Like

As Andre-K Pointed out, there are few ways you can test this.

First fly it, gain some altitude and then click in way point.


  1. Create a waypoint mission and upload it. I am asusming your way point mission is somewhere start mid air, with right altitude. Question remains you want plane to land on its on or want it to circle once the way point are done?

  2. You take off in stabilize mode, fly around and then enable waypoint.

Option 2:

  1. You can enable way point while the plane is on the ground. It takes off reach the altitude it needs and then fly to your starting waypoint and will begin the mission.

read this entire chapter:


Also, this guy made some good videos https://www.youtube.com/watch?v=rui2Trps2yc

Disclaimer: ArduPilot documents are the best thing ever happened to bored humans on the planet after we learned to grow crops :slight_smile:

And post some pics and video. Its always fun to see what others are doing.

ok, I will try. Thanks

What did you end up doing?