Taking off the aircraft without controlling the remote controller

2023-08-12 11-38-17.bin (866.7 KB)

FC : CubeOrange (not PLus)
Firmware: 4.1.0 Stable
GPS: Here 3

First of all, please understand that the firmware is not up to date.
It was a drone that was manufactured and sold last year, and it was confirmed that abnormal symptoms had occurred. I’m posting this to ask for help because I don’t know the cause.

Symptoms include:

Start up and the motor is at idle.
All controller sticks are neutral and no sticks are controlled.
Suddenly, after one second, the drone takes off and lands with all motors reaching their maximum PWM levels.

I tried diligently analyzing the logs to figure out the cause. I’m not sure why in the log all the motors are at full without remote control.

Also, I wonder why the values of Des ROLL and Des Pitch changed when the engine was started without the intervention of the controller.

Flight is an aircraft that has been tested many times before the situation and has flown well.
(I had to calibrate the compass often, but…)
In the latest stable state firmware, the priority IMU is changed to 1, and the fast reset function is added.
Whether the IMU bug can cause such symptoms… Is it a problem that can be solved by just changing the firmware? Ah, I wonder if I need to change the FC.

Could you help explain what could be causing me to be missing something in the logs? thank you

It appears you have a hexacopter with about 25inch props, but you havent set up voltage failsafes or geofence.
I definitely would do those immediately. Use the Initial Parameters calculator in MissionPlanner and select the “suggested settings” too, then accept all the voltage and fence related changes.
Also update to latest stable firmware, or at least 4.3.7

I would say you have a “old-fashioned” RC receiver that needs to be bound with all the RC inputs in exactly the way you want when failsafe occurs. The copter has been armed without the transmitter turned on, the receiver is already in its failsafe mode and channels return to how it was bound.

So what you would need to do is set your transmitter to minimum throttle then trim it down as far as it will go, make sure your pitch and roll are centred and all switches are in their normal positions. Now bind the transmitter and receiver.
While in that state, go to the RC Calibration screen in MP, check what the throttle PWM is now (but dont calibrate or change anything)
Check that FS_THR_VALUE is just above the trimmed throttle PWM. So if throttle was showing 930PWM set FS_THR_VALUE,950
Now set your transmitter back to normal - undo the trim so the throttle is operates as per normal.

Let us know if that is not the case. Supply transmitter and receiver details.

The best solution is to get a receiver that does true SBUS as that protocol includes a “signal lost” flag regardless of throttle level or other channel combinations or positions.

thank you for your replay xfacta.

I set arming check to 158. Geofence was not done because it is a gas carried from the mountain.
I am upgrading the firmware. We will enable all arming checks in the future. Thank you.

However, I don’t think the controller can be considered a Failsafe state at that time. I wonder why you can think that way… After starting the drone with the controller, the output of all RCs in the neutral value RC3in (throttle 1500) mode loiter was 2000. Could this situation be FailSafe for RTL?..
At that time, the mode did not change.

My controller is a T18 Jumper.
The receiver is an R8 receiver.

Maybe I misinterpreted your log and description, I’ll think about it more.

1 Like

That reciever can still be set to “Hold” or “Custom” channel outputs, but the prefered setting is No Pulses. You will have to go into your transmitter settings and check, as per the manual:

Failsafe is a useful feature which is for a preset channel output position whenever control
signal is lost for a period.
Follow the steps to set Failsafe for channels necessary :
Failsafe for receiver supporting D16 RF mode setting can be set via radio interface, which
support no pulse, hold and custom
three modes for each channel.
For Jumper T16,Taranis X9D/X9D Plus/X9E and Taranis Q X7, turn on the radio, go to: MODEL
SETUP/Internal RF/Failsafe.

The Jumper R8 will work fine in “no pulses” if you are using the Sbus output.

Side note if you have trouble with the bind: Just watch with the multi-protocol module because some of the early R8 were FrSky D16 and later were FrSky X2 D16.

First of all, thank you for writing to help me with my difficulties.
I am using CubeOrange connected to sbus.
Excuse me, but I’m curious on what grounds do you think the remote controller failsafe has taken?
There are no FasilSafe messages in the logs. All signals from RC1 to 4 came in without interruption.

I thought this problem might be an IMU problem, so I thought it would be solved by upgrading the firmware.
If it’s a controller signal problem, I wonder if there should be any symptoms on the log… but it’s hard to judge with my thin knowledge.

Of course, in the future, according to your advice, I will set up and familiarize myself with the RF FailSafe of the remote controller T18. thank you