TAKEOFF MODE motor doesn't start

Hello, I am trying to launch my plane in TAKEOFF mode but the engine never starts. What is the correct takeoff mode procedure?

You have TKOFF_THR_MINACC set to 5. That means the FC needs to sense an acceleration of 5 m/s/s before the motor will start to spin. This is how you set up “Shake to Wake”. Look up Painless360 on Youtube. He’s got a great video about it.

Yeah, I set it up according to the video. But I’m shaking on the field and nothing.

With my planes, I point the plane in the direction I want to take off. I Arm in FBWA then switch to Take-off mode. I give the plane a shake while keeping the direction where I want it. At this point the motor starts and I throw.

If you can, post a .bin of an attempt. Maybe something else is going on. Has the plane flown normally in FBWA?

Here is my attempt, only in my room without a propeller because of storm.


Probably this is the reason: You have THROTTLE_NUDGE enabled and your throttle input is at zero throttle.

Hi Martin,

It does not works indoors. You need a healthy GPS fix for any real attempt.

So should I disable THROTTLE_NUDGE?

I would first test to see if that was the cause by leaving the throttle at 50% when “throwing”.

So, I was on the field today. When I armed the plane in FBWA mode, the motor sometimes spin a little, but not much. Then I switch to TAKEOFF mode and in 2s motor started to spin fast. I throw the plane, it flies 3 m very steep up and then turn to ground and crash.

Here is the log.

Then I armed again in FBWA mode, the motor sometimes spins too but I throw the plane a did manual launch without any trouble.

Log here.

The plane really needs more tuning. There’s lots of oscillations in the pitch and roll. If another turn with autotune doesn’t fix it all, you might want to set RLL_RATE_SMAX down to 140 or 130 (same for pitch)

I think the throws were too nose high. If you’re sure your throw is flat (~5degrees nose up max) then you should check the center of gravity. It might be too far back.

I did autotune twice already, but I will try it again. Hope it will help.

Today I did autotune again. Auto modes worked well. CG is centered. Then tried takeoff mode. I throw the plane flat and straight. A few meters flew well, then pitched full up and turn left, and then hit the ground. I think I won´t try it again :grinning:.


I’m traveling right now so I can’t look at the log. Sure sounds like a stall. Are you using the takeoff flight mode, or auto takeoff in an auto mission?

Absolutely fine, I’m using takeoff flight mode.