TakeOff in FBWA : Roll attitude control doesn't respond to RC input


I did flew for the first time my ASW28 glider, 2.5m wingspan, running Arduplane 4.3.5 on a MRO X777 2.1 flight controler. AUW is almost 2kg.
Servo function are using Differential Spoilers, to take benefits of the crow braking at landing.

At boot time, before arming was done (and logging started) , my RC has triggered a AUTO TAKEOFF flight mode. Then I switched to FBWA (before arming) until takeoff happen.

I did launch the plane/glider by hand at 21’23", and everything went ok, except Roll attitude control that did not responded at all to my inputs on my RC:

At 21’44", I switched to RTL and the plane went back to Home :grinning:.
Seeing that everything was ok , i decided to switch back to FBWA mode to try to regain control on the plane, and it worked fine. Finaly I was able to land properly after almost 10 minutes of flight.

We can see in this charts that attitude control is not working before switching to RTL.

During this “loss of control” phasis , Servo output 1 and 6 (ailerons) was stuck to their max values

So it seems that arduplane did the right thing to do…

How to explain such a behavior of the plane ?
I have some hypothesis :

  1. wind was too strong to be handeled by moving surface / aileron. EKF3 estimated wind speed under 5m/s . I made some modification to increase the width of the aileron. so i am not convinced it is the right clue to explain the bad behavior.
  2. Issue on aileron Servos : but why it would have worked properly just after switching to RTL? what could be the root cause ? interference due to power lines , but why only during this takeoff phase ? Servo Voltage is having a strong 5V+ voltage for the whole flight.
  3. Vibration was very high at takeoff time, with tons of clipping:

    How could vibration explain such a behavior ?
  4. [EDIT/Suggested by @Scott_Nunan ] due to auto takeoff mode at startup, could Arduplane tried to level wings until gaining a certain altitude to avoid dragging wingtip ?

Please find log here: log156.bin - Google Drive


Was it to do with the auto takeoff mode, isnt there something where wings are kept level intil gaining a certain altitude to avoid dragging wingtip. I launch the same airframe in fbwa using handlaunch but mine is heavier i believe. I would remove autotakeoff from flightmode selection and try again, though thats only a guess. Do you still have effective roll control with crow braking? I find it lands well just with flap and i have no problem slowing it up by raising the nose.

Thanks @Scott_Nunan , I added you suggestion as a fourth hypothesis.

I have used crow braking only to the latest millisecond before touch down, so i don’t have yet any feed back on roll control… sorry