Take off Hand launch does not flying straight

Hello, everyone. Can I have some help here?

I arm the plane heading to the direction where the plane does auto takeoff. I gently lift the plane without changing its heading. and shake to wake. Toss towards in the air. The plane always turn left immediately.I have uploaded the vedio from the cam on the plane and third person view together with the flight log. I have tried about 10 times hand launching. I can see the message from the screen with direction degree. is it possible we can set this number.


what is happening is in the initial part of the takeoff (until it reaches TKOFF_LVL_ALT) it is just trying to hold level. Once it reaches that altitude it then recomputes the target position based on the path from the original takeoff location and the current location.
The roll controller is not managing to hold the plane very level during that initial climb. The problem is your plane has offset ailerons and the roll controller doesn’t manage to compensate well as it takes time for the integrator to build up.
I suggest doing the following:

  • lower TKOFF_LVL_ALT to 10 so it locks in the direction sooner before it has gone so much off course
  • set SERVO_AUTO_TRIM to 1 so it learns the trim offset needed for your aircraft, so the next flight it will takeoff more level

Thank you @tridge

I have tried with your suggesttion setting. Is it ok to have servo_auto_trim activated all the time? or needs to be deactivated once the trim were all set. here is the log link. the plane still turns left. as my plane does not have compass on board. I run it on the ground for several turns to gain the right direction of degrees. then I switch on the takeoff mode. Would it necessary or helpful?



that should not be needed

Sorry for intruding into this thread, but I had a similar problem in TAKEOFF mode problem 3 months ago - plane was not climbing in a straight line, drifted to the right (and almost hit a tree). I was then told to add a compass, so I did that, but haven’t tested TAKEOFF again since then.

Because there was something else, that was never explained when I posted the problem: The plane was also ‘pausing’ during the TAKEOFF climb. It descended briefly, before it resumed climbing. And it would be great to to know why before trying the mode again.

Here’s the log: https://we.tl/t-urcRtyBMi6 - many thanks in advance!