Tail servo with gyro problem

Hi Again,

I am not sure what to think about this one.

My second traditional Heli, same Xcell SE99 frame, but this one I left the Futaba GY611 on it (Lazy and the tail was so solid why mess with it). History of this heli is 3D, and it flew perfect before the PixHawk conversion.

The only change from my first Heli setup is I configured it for tail rotor servo with gyro. On the first spool up it went nuts in yaw before it came up completly on the governer as soon as I nudged the rudder stick. Nuts I mean the tail wagged violently back and forth each time with a larger amplitude. I checked the tail rotor movements are all correct, gyro response and direction are correct (nothing backwords). I reduced the gain on the tail, same result just much less violent. This heli just flew with this setup and exact settings before installing the PixHawk, so I am thinking it is not the GY611 gyro or servo.

changed the setting to “servo only” and tried again. still not right, but I could get the head speed up on the governer, but when I gave a yaw command, it got ugly. I reduced the GY611 gain to “0” and put it in normal mode, now it is flyable. Even with the gain at “0” this gyro is still plenty active.

I realize I have two control loops running now and this was not my intent. The tail with this gyro was so good, I had to try it. In the below graphs, there is somthing funny going on with the desired yaw graph lines below. In the auto mission graph after line number 30k, it did a wag off of waypoint 3, this can be seen in the desired yaw graph, I think this is the root of the problem.

Vibrations are low on this machine and everything else is working fine.

any ideas?


I found a thread on the multirotor side of the forum. A gentelman had a pitch and roll twitch with his quadcopter, he logged the event on all channels with the RCIN and RCOU. Unfortunatly, I was not logging RC data so I could not compare (changed that now).

The source of the problem was his Futaba reciever was in normal mode. He switched it to “Hi Speed” and his problem was fixed. this seems to be a Futaba S-bus thing.

So, the reciver I am using is an R6208SB Futaba reciever and it was in the default normal mode. I switched it to “Hi Speed” and nothing changed, still the same problem.

I removed the Futaba GY611 gyro and servo and installed a JR 8311 on the tail. I replaced the Futaba servos because it is not compatable with the PixHawk with it’s 760ms center.

Heli flies fine now with the same settings as SE99#1. flew a little mission with an auto land and all is good.

Unfortunately, I did not get to the root cause of the problem, it could have been the 915MHZ telemetry transmitter position close to the gyro sensor. I thought of this after I changed the servo so I did not get a chance to unplug the TX and test.

Maybe I will test it later, but for now my lazyness has cost me a few hours of testing and troubleshooting.

I attached my current tuning parameters for others and the reslults of the JR8311 servo on the tailrotor. FYI my Heli has a flybar and is in flybarless mode (695mm blades).


Hi Bobby,

I can’t help much with the gyro thing based on the info you have provided. I’m not sure what the problem there was. I thought that code was working but it’s been a while since I looked at it and not many people using it anymore.

On your current setup, so those parameters are what you’re flying with? I would try adding some Yaw Rate I term and D term. I’m actually surprised it works well without any I term at all. You must actually have a pretty good mechanical setup.