System Identification Flight Mode

I’m using a Pixhawk 2.1 on my Align T-Rex 500. I’m trying to use the sytem identification mode operation. I can choose it from the available flight modes, but when I try to switch to that mode, I get a message saying that the mode does not exist. I’m also running the lastest version of MissionPlanner. Also, I cannot find the SID_AXIS on the parameter list. Only SYSID parametera are availabe.

What can I do to finally be able to use mode?

I suppose because it’s an F4 it’s feature limited including perhaps that feature. Try the Custom Firmware Builder and enable it in the build.


By F4, do you mean the Omnibus?
Due to the flash memory limitations, I must try the custom firmware builder to choose which features will be available?

No, that Flight Controller has an F4 processor and many of those are feature limited.
Yes, try the Build Server, enable that feature, disable something else you will not use and see if it builds.

1 Like

@Cristo1620 what version of software did you load? You may try to use an older stable version. I don’t think they have fixed the build server so that you get a stable version. I believe it gives you Master. By going to a previous stable version, it will go back to where sysid was part of the common build. I am running 4.0.7 on a pixhawk 1 and sysid is part of the build. So start with 4.2.3 and work backwards. The next major release would be 4.1.5. You can select these from mission planner setup tab.