SV drifts a lot right after a 'long' fast maneuver

So I’ve noticed a lot that when in GPS Hold:On mode that if I move in a single direction for a period of time (4-5 seconds) especially really fast, that when I let go of the stick that it’ll continue to drift in that direction.

Additionally, if I let go of the stick and yaw, it’ll continue drifting in the same direction it was going. This seems like a Kalman Filtering thing. In my time with aircraft KFs, if you did a specific maneuver for a “long time” then some of that tended to translate into KF drifting. Scaled up, long time was in minutes. For example if an aircraft orbits for a long time, it’ll will throw the CEP way out. My expected performance with a EKF (GPS stamped KF) is when I let off the stick that it’ll (relatively) quickly come to a stop and try to hold the position where it came to a stop. Instead, I find myself having to fight it to stay in position for a few seconds manually, before it’ll correctly stay in that position. Has anyone else seen this? Is this the expected performance?

Not much help but both of mine do the same thing.its got to be somewhere in the settings but i dont know enuff to start screwing with a majority of the settings lol

Wasn’t it mentioned somewhere that SV put in a little extra code that “automagically tunes while you fly”? I thought I saw that somewhere. Not talking about Auto_Tune mode, but something else. I noticed another talking about how their SV has started drifting after letting off the sticks in loiter mode. Said it didn’t do that when he first got it. I’m wondering if maybe it is “learning” and saving something that in turns is making the position hold a little sloppy…

Mine is doing this as well, and I pulled logs and there is always a compass issue. No matter how many times I recalibrate, re-do factory defaults, motor cal it still wanders all over in GPS mode. Manual mode it’s fine. I usually get a compass cal fitness of 6 or lower. Log attached. YouTube video on how it hovered while new posted as well. Now it wanders around like a drunk sailor. Have never even crashed this thing.


Same here. I’ve noticed all my logs showing compass issues.

I noticed the toy_mode.cpp does some auto compass calibrations too…I wonder if that is messing with something…hmmmm

Also, I’ve recalibrated, but i haven’t confirmed directly after cal that it still showed errors. However, my logs after flying after a Cal still shows this error.

That’s exactly what I get as well. If anyone want’s to look at a log, I posted one before. I think there is either a hardware or software problem. I have 2 Solo’s, one stock and one with HERE and Green Cube. Both of them calibrate and fly no problem in same spots this gets error. Solos have like 2% interference.

Of course, have tried calibrating and flying the SkyViper in a bunch of areas as well…no luck.

Anyone else still having this issue? Still not having any luck with this thing. Getting good compass cals, but toilet bowl and bad logs.

@Peen what is toilet bowl mean?:joy:, I thought this happen to me, I fly 10 SV automatically in the same time with my GCS,when holding position , 9 performs acceptable, but one drift badly every time even after good calibration, post is here Guided Mode Hold Specified Position Best Practice?


i get the bad compass as well no matter how many times i recalibrate too. if anyonw knows how to solve it ?