Surge in motor speed when raising throttle for take off in stabilize mode

When I get to around mid throttle there is surge in the motors speed making the quadcopter uncontrollable. It happens intermittently. The flight controller is a 3DR APM 2.6 with Arducopter V3.2.1. I would appreciate any guidance in what might be the cause.

Here is a link to the bin file:

I too am having a throttle surge problem with a newly built Tarot 650 Iron Man quad, using an APM 2.6 and running firmware version 3.2.1. The aircraft configuration is:

40 A HobbyWing OPTO ESCs
T-Motor Navigator Series MN3520 KV400 motors - mounted underneath the chassis in order to avoid long power/ground leads that can cause large voltage spikes due to the ESC switching action.

I ran a motor test using Mission Planner using a telemetry link established between aircraft and laptop - ran each motor for 3 sec at 25% power - no problem. Ditto running all four at once. Then I anchored the floor, armed and throttled up the motors and observed the surge problem, so it appears to be something in the receiver/APM link.

I calibrated the ESCs individually and all four again out in the field.

I have searched for throttle surge issues and got several hits though they seem to be discussions on various forums from several years ago. I have updated my copy of Mission Planner and it has V3.6.3 firmware. I am wondering if reflashing the APM using the later version of firmware might solve my problem?

Would defiantly recommend you update to current hardware and firmware. The move to chibios has greatly improved the range of affordable flight controllers.

Not to much we can do to help you out on the older firmware, no one remembers how it works. Anchoring it hard down to the ground will make funny stuff happen the copter does not respond to its small change in throttle so it trys harder and harder. If your anchoring it down it should be a fairly loose tether so it can hover a foot or so off the ground without the tether pulling it too much. For tether testing (or flying of any-sort) its a good idea to set up motor estop on a transmitter switch (i have no idea if that is available in your old firmware)

I did update to V3.6.3 to no avail. I produced a video:

APM is not supported on the latest stable (3.6.3), the last APM release was in 2015. This is somewhat hidden by mission planner and the latest folder on the firmware server. ie the latest folder does contain the latest firmware for that hardware, its just the latest firmware is nearly 4 years old.

The vid doesn’t look too bad, certainly it could just be caused by strapping it down. I would go outside and tentatively try it in stabilise mode. You could use a short length of rope if your worried about it flying off.

Thank you for your response. I look at all parameters pertaining to the throttle/motors and nothing jumped out at me. I agree - I should take it out and try again. I’m not worried about it flying away - typically on my first test flight, I program the following modes: Stabilize, Loiter and RTL. I take off in Stabilize and try out the flight controls - pitch, yaw, roll; if everything goes well, I then switch to Loiter to exercise the compass/gps. If it maintains position, I yaw the aircraft in both directions to insure no toilet bowl effect, and if that goes well, I switch to RTL and let it land autonomously.

During initial flight tests, I enable a geofence to insure that the aircraft stays within my prescribed boundary.

After subsequent test flights, where I exercise the ground station, voltage fail safes and do an auto trim, I will feel confident enough to install the gimbal and video transmitter, after which I will to an autotune.

Thanks again for your suggestion!

Test flight failed. Took off in Stabilize mode seemed to be okay but suddenly started dropping. I goosed up the throttle and recovered - climbed up to a higher altitude so I could recover if it suddenly lost power. Flight controls seemed okay so I put it into Loiter - worked okay. I yawed the aircraft left and right - no problems. Then I hit RTL - it turned around and started heading back to the launch point when suddenly all four motors quit and it fell out of the sky:

I recovered the Dataflash log:

Looks like the APM suffered a brownout. I don’t know what would cause it - the APM was getting power from the APM Power Module and the R/C receiver was being powered by a Castle BEC as I was using OPTO ESCs.

bad luck,

Could it be that the bec was also trying to power the APM and fighting the power module. I think you should only connect the ground and signals of the rc inputs and outputs. I vaguely recall there is a jumper or solder bridge that connects the 5v input rail from the APM to the inputs and/or outputs. It sounds like in your case this jumper should be removed.

If this was the issue it should show up in ground testing without the motors powered.

Not really sure what else It could be except a hardware failure.

The APM came with the jumper removed. The connections between recerver and APM were just signal and ground leads. The signal leads from the ESCs have all three wires, but sine they are OPTO ESCs the red (middle) wires should have no voltage. The BEC was just powering the receiver.

All I can think of is that somehow the APM power module failed somehow, but I don’t know how to test. I specifically bought this particular P.M. because it was supposed to accomodate 6S voltage.

Can you post the log file from the APM crash flight?
We can probably see a whole lot more if you do.

I can - will do later. LAst night, while pondering the issue of connectsions between the receiver and F.C. I suddenly realized that I had a servo connection between the gear channel and channel 6 on the APM for autotune purposes and I neglected to removed the middle (power) wire. I just went down to the basement and examined the wires from the receiver and contrary to my last post I DID NOT remove the middle red wire from any of the flight control channels as I thought I did. So perhaps there was power contention between power from the receiver and the power module???

A cursory glance of the damage suggests to me that only the airframe is destroyed - ESCs, motors appear undamaged since they were powered off and the fall was 28 meters into a field. GPS mast is intact, flight controller as vibration base are all intact. Will have to examine the motors to make sure no dirt found its way into the innards.

I might be able to repair by buying a new airframe…

Been a while since I first posted about this. Since then I figured out I had some issues with a receiver. I can’t remember if it was the cause of this particular issue though.