Strange LAND behavior when testing failsafe

I would like to configure my failsafe behavior such that when radio contact is lost, the craft immediately enters land mode and starts descending. Simple, right? While testing that behavior while connected to Mission Planner (props off, quad sitting on my desktop), I sometimes see the motor speed increase dramatically for several seconds before it decreases. I would like to defeat that so that the craft does not climb. I don’t want it getting higher if my radio link is not operational, as I always fly in open areas with no obstacles in the immediate area. I just want it to come straight down. I noticed this behavior seems loosely correlated with how high I have the throttle set when I test the failsafe.

I have both RTL_ALT and RTL_ALT_FINAL set to zero in MP. My Battery and Radio failsafes are both set to LAND in the FailSafe screen of MP. Can anyone offer additional guidance? I’ve trolled the online documentation and existing postings, with no luck.

Please provide tlogs and/or dataflash logs to help troubleshoot your issue.

Sorry, Should have done that. Telemetry log is attached. Note that the quad was initially not armable - you can skip past that. The time period of interest is after I turned off my radio to invoke failsafe.
Failsafe DOES get invoked. The behavior I’m interested in has to do with throttle levels after that. A second or two after failsafe is invoked, they will go up for seconds before coming back down.

I tried creating an APM data log as well (logging almost everything), but the file was too big to upload here. If there are specific parameters you think would be useful, please just let me know the LOG_BITMASK value to use and I’ll rerun the experiment.