Strange issues connecting with Droidplanner

I know… there are a million threads on droidplanner connection issues! I think I have read them all and haven’t found one like this.

Essentially it seems that my Droidplanner is having issues initiating the telemetry stream from the vehicle. I hit connect and it says “Connection Failed”. I can see that data is being transmitted from the lights, and also by hooking another radio up on my PC with a terminal running. If I start a PC with mission planner and another radio, it works immediately. If I disconnect that radio and hit connect on Droidplanner… it connects and works immediately every time.

I have a Note2 phone and a Note 8 tablet… works identically on both. I thought I might have power issues (from reading other threads) but now I am powering the radio externally. I have two vehicles, both with PixHawks and 3DR radios (same behaviour with both). All the 3DR radios are the “v1” version. Pixhawks are running APM:copter 3.3rc5. All my radio’s have SiK 1.7 firmware.

Some other oddities:
[li]If I start off using Droidplanner, getting connection failed messages etc, then try to use the PC/mission planner… it won’t connect. I have to repower the vehicle and then MP works immediately.[/li]
[li]Once DroidPlanner connects, even if I restart the vehicle it will reconnect as long as I don’t hit “Disconnect” in DP.[/li][/ul]

Any suggestions? Would it be worth upgrading all my radios to SiK 1.9? It is a bit of a pain especially on the vehicle side since I don’t have an appropriate cable to hook them up, but I’ll do it if it will fix this.


Great - finally someone else have the same issue. BTW: I tested SiK1.9 as well. - no joy.

My Droidplanner/Tower was working fine since start, then - most likely after some crazy update of the application, it does not work.
Note that I did not update my Android OS.

Anyway - everything I’ve tried is here:
Please add to the issue, so the authors see that it’s a real issue for more than one person’s devices.

I have an HP 7 G2 and a ASUS TF201 tablet and they both work just fine. When I plug in the USB cable the Blue end goes in the tablet it pops up a window asking if I want Tower Services to connect. I say OK to that and then I start the Tower software where I then hit connect with no issues.

Both of my radios have a DF13 and USB adaptors.


yes, iseries, we are aware that it works for some people, and how it’s supposed to work.
I too get all the usual popups and the only difference is the error on “connect”.

Like I wrote in the GIT issue, both old and new radios are tested , and other USB devices work fine on the OTG cables/adapters tested.

One thing you can verify for me, if you like:
Connect only one radio to Tower, (no UAV powered on) - you should see the green LED flashing , no red.
Now - press “connect” - do you see the red LED flash a few times ? - That’s the traffic I captured , not knowing what it is ment to do.

Will post on your bug thread.

Another data point is that I tried Andropilot last night and the behaviour is essentially the same. Do Droidplanner and Andropilot both use the same communications libraries?

I will say that it used to work better than it does now… but I have always had some troubles getting it to work.

Well, both Droidplanner and Tower stopped working for me too.
I’ve uninstalled, and reinstalled all three.
Also, I did delete application settings for them in application manager.

I can only assume, something messed up the way USB serial work on my devices.
The only applications that were used on both my android devices, were these.

Do you also get the behaviour where if you connect with Mission Planner and then try with droidplanner it works?

It seems to me that either the remote radio or autopilot are getting put into a state where they don’t send heartbeat packets. Something about the DP startup/connect is causing it to error out.

no,I am not using Mission Planner, using APM Planner.
And no GCS i supposed to fail whithout mavlink /hearbeat being active, GCS software may give a warning, but it is supposed to just keep waiting.
And the heartbeat is not generated by the radio, but is a part of autopilot’s mavlink output.

I am about to add some Android log that developers may find useful.

I don’t think this is actually a droidplanner issue… although DP may be irritating a bug that normally isn’t a problem.

Once you hit “connect” in DP it stops heartbeat packets from being sent by the vehicle. Something in the messages the DP sends stops them. Unsure if it is the radio blocking them or if the autopilot stops sending them. After this nothing can connect to the vehicle until it is restarted (computer, droidplanner etc). From looking at the serial dumps it seems that DP is just sending Mavlink packets which should be fine.

I am going to verify that restarting the vehicle radio along doesn’t clear the issue. I suspect I will find that it doesn’t.

it’s not stopping mavlink heartbeat.
it just fails with an error regardless vehicle status - the error should never be seen, even without any vehicle, it should just sit and wait for telemetry - maybe just warning about no heartbeat as if connection was lost.

Just check out my Android log in git , it fails milliseconds after it opens port.

maybe you can make a log of your own ? that can help, guessing can throw people off.

I have found that the connection will not work from Tower / Droidplanner on my Nexus 7 if the radios have flow-control enabled “Connect failed”. They do work with Mission Planner when flow control is activated.

You can adjust the radio settings from mission planner.

I initially tried updating to 1.9, which did not improve the situation.

I haven’t had any issues since I disabled flow control on the autopilot. I think FC was getting erroneously autodetected sometimes by the autopilot.

I also changed my channels from the default. Since I did these two things I have not had a single connection failure.