Strange issue

I have a strange problem. My Pixhawk was flying a delta wing for some time. All was perfect. After a period of three months when it was not flown, things changed. When in RTL and AUTO, it climbs to the determined altitude where it starts to oscillate up and down while the wings are levelled. It does not navigate.
To solve this I upgraded to the newest stable software APM 3.4.0 but it does the same.
I calibrated the ACC and Compass. I got the calibration successful message.
I did not try the other auto modes as I have just started to work on it.
What puzzles me is that the STABILISE and CRUISE modes are working perfectly. These fast 2x/sec up and down changes do not happen.
I was getting ERRORS velocity variance, Compass variance, EKF as red or orange, Position horizont variance, Terrain altitude variance. After the ACC and Compass calibration it stopped. The EKF gets sometimes orange.
I have no idea what to do next to solve it. Any suggestions?
This is the Pixhawk SD card TELEMETRY
As an web address

Your TRIM_ARSPD_CM is very high at 2100.0000. You plane will try to cruise at this speed in AUTO mode which is quite fast.
Further your PID values are VERY unusual. I suggest you try to do an AUTOTUNE on the plane again and see if that resolves the issue.
Thanks, Grant.

Thanks for the reply. I Auto-tuned today. It was very windy. I did it anyway just to find out if the up and down oscillation disappears. And it did. No more oscillation, however the pixhawk is not able to navigate along the programmed track. According to the base station it keeps reloading the first way point. RTL works flawlessly.
Route1 --The plane got lost totally
Route2 --The plane circled around the first way point.

You have arming turned off. Turn it back on and see if the arming checks find any problems. You should also calibrate your airspeed sensor before flight.
Let us know.
Thanks, Grant.

I will do that. But why should it matter?
The airspeed was calibrated. The plane, after auto-tune flew very well.
The ground station did not report any errors during the flight.
GUIDED, LOITER, RTL all these modes were perfect. Only the AUTO failed.
The plane flew to the firs way-point and never left it, no matter how long it stayed there. The route was only three or four waypoints. None of the ones behind the first were ever attempted. Looking at the ground station, the orange “direct to current waypoint” line has never left the first way-point. I find that very strange.

I don’t know why your plane circled waypoint 1. I flew your mission in the simulator and it worked fine although once it finished the mission it circled the HOME location as there was no loop command in the mission.
Prague is a nice part of the world.
Thanks, Grant.

Thank you for trying to help.
I am very confused what it could be. If I am not successful next time I will wipe out the board completely and start over again. The spot I fly at is a hill and from there it is possible to see a big part of the city.
View it from a heli

This is the problem:
2016-02-03 02:54:48.36: CMD {TimeUS : 201450742, CTot : 4, CNum : 1, CId : 16, Prm1 : 0.0, Prm2 : 0.0, Prm3 : 0.0, Prm4 : 0.0, Lat : 50.1543960571, Lng : 14.3687438965, Alt : 60.0}
2016-02-03 02:54:48.36: MSG {TimeUS : 201450761, Message : Executing nav command ID #16}
2016-02-03 02:54:48.36: MSG {TimeUS : 201450816, Message : Resetting prev_WP}
Its resetting the prev_WP but I don’t know why. Its late here. I’ll look some more tomorrow.
Hmmmm, this could be a bug.
Thanks, Grant.

Another log
In this log, I Autotuned, tried GUIDED mode, RTH, Stab, and AUTO.
All worked well except the AUTO.
See my parameters file

Found it. You have RST_MISSION_CH set to 10 and RC10 is at around 1900 PWM permanently. This means your mission is CONSTANTLY being reset to the first waypoint. I’m talking being reset every 15-20 milli seconds! Set RST_MISSION_CH to 0 and fly again.
Thanks, Grant.

Yes, it is right. I would not dream to look at that parameter as I have never used it.
Thanks a lot. It now flies as it should. I do not know how the reset got in action. It must have been an accident.
Thanks a lot for the patience. Now I have a well tuned plane that flies perfectly. Thanks again.
Issue closed.