Strange Esc behaviour

I spent quite a time to figure out why the motors refused to start today.
Got my new Pixhawk yesterday and inslalled it this morning. Changed the connections from the receiver to the Pixhawk and did all mapping on my Graupner transmitter.

Everything went fine and after calibration I could arm. The Pixhawk went steady green. Set mode to Manual. All servos was working but motors refused to start.

My fault, I thought, removed the wings to check the connections but everything was OK. Moved the motor cable to some other servo ports but nothing happened!

To test I connected the Esc to the Receiver again and Yes! It was working.
Connected a working Turnigy Multistar ESC to Rc 3 and it was working perfectly.

Conclusion: Hobbyking YEP 30A (2-4s) SBEC does NOT work with the Pixhawk!!!

This is not a complaint! I disliked these Escs from the start and will change to Turnigy insted. They run perfectly on my huge octocopter with Pixhawk controller so I assume they will work as good as plane Esc.


I use the YEP 80A ESCs with my Pixhawk-based planes and they work fine. It sounds like you might not have a good calibration on your ESC. Why don’t you try calibrating it directly connected to your receiver first?

The YEPs are actually excellent for FPV planes due to their active freewheeling feature which makes them more efficient for long flights at low throttle which is common in FPV.

I hope you have the programming card for it because they (at least the 80A version) come configured for helicopters, have a ton of settings and are very difficult to stick program.

You may also need to double-check the value you have specified for “ARMING_REQUIRE” based on the ESC you use. See this page: … -throttle/