Strange behaviour when changing panel

My OSD is mounted at the ground, parallel to my Nexus 7 Droidplanner and only wired by the Rx, Vcc and Gnd.

It starts up normally, but a mode change by ch 7 (3 pos switch) behaves strange. At first the mode change worked but the panel 2 was distorted. Too many items were shown (not selected in the config of panel 2) and the display was shifted horizontally. I could however switch back between blank, distorted panel 2 and panel 1.

I tried to switch off all the warnings and now I can see panel 1 after startup, but switching (after waiting 60s) only blanks the OSD but switching back does not show panel 1 anymore.

I already reflashed the FW (v 2.0 Oct 2012) and char set to no avail.

In my radio setup in Droidplanner 2 I can clearly see ch 7 going from 1000 to 1500 and 2000.

I found a solution by downloading FW "Extra Pre release r727. Now the screen toggle works as wanted except that after a warning (GPS / Battery Low…) I can’t change the screen mode anymore.

Hi arachnida

Where did you find this firmware?


Jase :slight_smile:

Hello Jase,

here: … 1#comments

Look at the last pages for the latest version of the FW, the pre relase are stable.

Have fun,

Hi Arachnida

So is MinimOSD-Extra a different config tool to Arducam OSD? Confused???

Or do I simply use Arducam OSD and load 2.2 firmware in provided link?


Jase :slight_smile:

Nope, you have to use his own and latest config tool as it has many more options and settings. Also update the char set that comes with the config tool.

Hi arachnida

So to clarify there are two options for the MinimOSD?

  1. arducam-osd

OR (the more up to date???)


Each with their unique config tool and unique firmware.

If this the case then I hope by trying minimosd-extra I can toggle through screens.


Jase :slight_smile:

Good question! I think ArduCam is the name of the project, MinimOSD is the HW product.

When extra features are implemented in the FW the tool to configure them has to follow, so in most cases (but not always as some changes in the FW are minor) the tool is also updated. So always use the correct matching tool for the FW version. Easiest way is to go back from the last page of the thread and look for the latest release of both tool and FW.

I also see an official v2.2 beta is made public, you can try that one too.

For me the extra FW made it possible to change the modes by using an extra ch.

Hi arachnida

Great to hear from you. On the face of it, it looks like minimosd-extra builds on arducam-osd. If that’s the case then would you suggest the following?

CT for MinimOSD Extra


MinimOSD Extra Plane 2.2.hex

*Can be found at the bottom of list of minimosd-extra downloads.


Jase :slight_smile:

No, I meant the ‘official’ code 2.2 beta that can be found on the APM wiki pages or the extra code 2.4 r791 being the most recent of the extra branch.

BTW, do you have a plane or kopter? I have always been talking about the kopter version!


Hi arachnida

Thanks for the reply. It took me a while to find it. For anyone else looking for the latest version go to then click on Downloads > Advanced User Tools then scroll to the bottom of the screen.

MinimOSD Firmware v2.2(Beta)

I will let you know how I go.


Jase :slight_smile:

PS I’m using APM: Plane.