Strange behavior: jumps in the air


On the maiden flight of a 30" quadcopter with a 2400W generator from RichenPower I observed a strange behavior. Shortly after take off it started to jump in the air and the generator speeded up and slowed down.

Seeing the voltage graph, I suspect that the generator decelerated when it reached 50 V, which must be its normal behavior to protect the batteries.

My question is if those voltage variations that the generator produces when accelerating and decelerating are what cause the drone to jump in the air, or if it has to do with the vibrations of the generator or I simply have to reduce MOT_THST_HOVER.

Log file


Simply looking at this as any other large quad the motor outputs are oscillating badly being driven to some extent by the Pitch Rate controller. I can’t say if there any influence from the generator not having any experience with those but my guess is it’s not a factor.

Try dropping the Rate P&I parameters to ~.10 (from default .135) and see if you can get control of this oscillation.

Thank you @dkemxr , I will do that.

A question out of curiosity. Are you not using the generator functions in Arducopter for control of the generator?

Not yet. I need a cable GH 1.25 to Dupont 2.54 for data from generator. To switch generator I use a 3-pos switch instead of aux output of FC. I thing is safer to use a physical switch on the drone than a channel of the transmitter.


Setting ATC_RAT_PIT_I and ATC_RAT_PIT_P to 0.1 but RATE_Pout graph looks almost the same.

However, it seemed to us that the vertical movement was much more abrupt. In fact it was not possible to keep it hovering, it was constantly changing altitude.

It does not seem that the vibrations are excessive, visually it gives the feeling that it is not capable of hovering or that the throttle stick is very sensitive.

On this flight the generator has been kept throttled all the time as it should be.

I have reread all tuning documentation and except for the MOT_THST_HOVER parameter which is in 0.2 I don’t see what other change I can make. What would be the procedure to adjust that hover?

Log File


Right, no real improvement. Actually the next change you should make is a function of MOT_THST_HOVER so you are on the right track. Before that though set the Roll Rate P&I values same as Pitch. MOT_THST_HOVER is a learned value (with default settings anyway) which is accomplished by hovering in a non-manual Flight Mode. AltHold or Loiter will do. It will take a minute or so for the value to be learned. Then set these based on the saved value:

If you want to cut to chase you can use the CTUN>THo average value at hover. In this log it looks to be ~.46 So perhaps set the above values based on .46 and then do the hover test to learn a more accurate value. Then review the RCoutputs and the Rate outputs for oscillation.

I was asking about the Generator parameters as someone else was posting about issues with it.


It’s too windy to fly an untuned drone, but I’ve done this interesting experiment:
Without starting the generator, only with the backup batteries, I have armed and raised throttle to the point before takeoff. I got this graph:

This shows that the generator has no influence on the behavior of pitch jumps.

Is it normal that just by arming motors 3 and 4 receive PWM of more than 1300, while motors 1 and 2 receive 1220?

There is a point where the vibrations increase a lot and the Rate_POut starts to oscillate. This oscillation appears harmonic.

Log File


It is if there is a Yaw command. 1&2 CCW, 3&4 CW motors.

It doesn’t look like you made the PSC parameters changes.

For this test I momentarily reverted the changes to be able to compare with and without generator


Based on testing without taking off, I have obtained that configuring INS_HTNCH_FREQ=30 has reduced the oscillation. I have been able to do a little flight to verify, it no longer jumps in the air, although the Throttle control is very sensitive. The CTUN.Tho mean now shows a value of 0.32. I guess setting PSC_ACCZ_P=0.32 and PSC_ACCZ_I=0.64 will improve the ease of hovering in stabilized mode.

Log file

There is still oscillation in the outputs:
Update to V4.2.1
Set LOG_BITMASK back to default (176126), log is missing data.
The Notch Filter isn’t doing anything set for Throttle Reference and INS_HNTCH_REF set at 1. This needs to be the Hover Throttle value.
30Hz for a Notch center frequency is generally too low and could compromise RC control. First you need to reduce the motor output oscillation before setting the Notch parameters. Reduce the PSC values based on Tho .32 as you said. Make a Hover flight in AltHold, Stabilize will not update the MOT_THST_HOVER value. Review the log for output oscillation. It looks like this:

If it’s still present after you review the log reduce the ATC_RATE_PIT/RLL P&I values a bit and test again. When the oscillation gone use that log to determine Notch Filter parameters.

You can also look at the Pitch and Roll Rates. Pitch is terrible:

Thanks Dave

Could this effect be increased by the anti-vibration platform on which the FC is mounted?

Not much evidence for that, typically just tuning. How is the FC mounted?

FC position is rotated 90° and to the rear of the center of gravity. It is mounted on an anti-vibration mount.


Well, I have been able to do two new tests. Each reducing PID over the previous setting. But with LOG_BIT_MASK=176126 I don’t see the RATE and CTUN messages and I am not able to assess if it has improved.
First PID setting:
Log 1
Second PID setting:
Log 2


Breakthrough today (I think so).

As I have observed that the oscillation occurs as soon as I arm it, I have decided to do the tests on the ground with the drone tethered. First I have removed the anti-vibration mount and the vibrations have decreased as can be seen in the following two images:

Then I have reduced the P and I terms of the pitch and roll to 0.025 and this is the difference in RATE:


Vibrations have also been reduced:

The throttle setting is extremely sensitive, at 1250 throttle signal the drone starts to climb. In the flights it has been quite complicated to keep it high and land it without breaking anything, small movements of the stick produced large variations in height. Is there a parameter to smooth the throttle response?

On the other hand, setting P and I so low makes me fear that it is not enough to stabilize it. When I had them at 0.050 I already had a scare at takeoff. Do you think that a value of 0.025 can be dangerous?


Probably. Post the log.

Here is:


Nothing to see in that log. You have to actually fly it.