Strange battery voltage

I dont know what is going on but my battery monitor shows strange values during flight. As you can see on pictures its jumping rom 12V to 3V. I also get many errors like flight mode 15, radio-2, radio-0, radio-1 err failsafe, ekf-check-2, etc.
Also tried different battery but no difference, measured them on multimeter and they are fine.
Please help…

Have you tried a different power module?

No not yet, it worked quite good before

This is graph two days before. Only difference is battery was not fully charged and settings in MP was mot_hover_learn 0 . After I changed it to 2. Can this cause a problem?

I don’t see how changing that parameter would cause that behavior with the battery. Only reason I thought of the power module was because you said you tried another battery and the same happen.

So I tired to change power module and test again.
At start battery was 11.42V after battery safe was triggered in 2 minutes, power moduel showed only 2V
I unplugged battery and measure, it was 11.27V

Btw voltage from power module when copter is in standby jumps from 11.38-11.46V Is this normal? Is it possible that it gets some interferenfe from wiring (especially during lower battery voltage) between power module and pixhawk?

Some simmilar problem with power moduel here:

Any solution to this problem?

Change the cable between powermodule and FC.

what sort of cable should I use?

The same type, just a new one.

Why ? The cable is in a good shape, doesnt make sense to me…
It might be interference from ESC as was suggested, but dont know how to prevent it…

I just had the same issue. The voltage and current readings suddenly fluctuated with no apparent reason. While testing everything, I touched the cable and the voltage read normal. I removed my hand and the voltage dropped again. So I changed the cable and everything is ok again.

I tried to shield power module and cable to FC with aluminium foil and move them further from ESC cables. But it doesnt seems to have any difference.
Interseting thing is, that problem with voltage starts after few minutes of flight. I will probably go to Mauch power module, hopefully it will make any difference.

Looks very much like a dry joint in your power wiring.

Have had a couple in the past where the wire was soldered onto the power module, done too quickly, not fused, and only the heat shrink was holding it in place.

Just a thought.

Well I have 2 same power modules. Tried both. Soldered myself (from bat to PM). From power module to FC there is no soldering…

I guess the connector on your FC is broken.

I switched power module to Mauch and now its superb. Problem si gone and measurement is more precise and stable. It does worth the money.

I had a similar issue with my hexacopter - would trigger battery failsafe. Switched to Mauch sensor and issue went away. I can’t recommend Mauch hall effect sensor strongly enough for anyone wanting to build a reliable solution.