Strange autotune behaviour on large Y6 (28in prop)


Come across some strange behavior trying to autotune a big y6 with Pixhawk 2.1.

Autotune is setup as a CH_7 option. Procedure was as follows:

Takeoff in stabilize, switch to alt-hold, engage autotune. Ground station reports “autotune started” and shows flight mode as “autotune”

Every time the pilot positions the copter and releases the sticks, the copter will do one twitch and then stop. It will not twitch again until the pilot again moves the copter and then releases the stick.

My initial thought was bad stick centering, but we have tried now with futaba and with taranis, and have double checked there are no trims or anything that should stop it centering.

Aircraft is a Y6 using Tmotor U10’s and 28*9 inch props.

Does anyone have any suggestions?
Logs are here:


I don’t see why you’d have to re-position to get one twitch.

I do see a large yaw imbalance. Even motors and Odd motors in two disctinct gangs. Maybe a mount has rotated?

Thanks for taking a look.

In a coaxial setup, it is my understanding that all the motors on the bottom will have to work harder, which is shown in that graph.

The motor mounts bolt into square tubes so it is not possible for them to rotate.

I have had the exact same happen to me with a smaller 10" propeller quad. I found that I too needed to “counter twitch” a roll or pitch; or poke a quick Yaw to get auto tune to go to the next twitch in the process . Same as you experienced. Did a whole Roll auto tune that way once!
I THINK, but can’t remember for sure- that once I reset the Throttle Mid point ( this was before the Newer Motor midpoint settings) to center the throttle stick; that the auto tune problem went away. Might be worth checking if no one else has any good ideas.
Also my frame arms were a bit flexible and that couldn’t have helped. I was using a Pixhawk mounted in one of the AV Domes. Once resolved hasn’t had happen again.
Good Luck,

Thanks Joe,

I have checked and rechecked the radio cal values, when it is in autotune the desired altitude stays constant which should indicate that the throttle is dead center. I even widened the dead band to make sure.

I took a screenshot which shows the problem very well

As you can see the vehicle only does one twitch just after the stick returns to center.
Desrol is 0 when stick is released so the sticks are center.

I will try tuning throttle mid to see if it helps!

I am confusing.
How to reset the Throttle Mid point?

On AC3.4 throttle mid is no longer a parameter, it now automatically learns the value in alt hold.