Strange APM behaviour - B - LED

Hi all, wondering if anyone can help out.

Just building my second APM based plane to go with my 2 arducopters. Getting to point where installing all electronics and have hit a problem im stuck at.

Heres the steps ive taken.

APM erased/reset and updated with latest v2.7.4b

Power up the board which has GPS/433mhz telemetry, RX all powered via UBEC.

Servos are connected and powered by seperate UBEC. Jp1 removed.

APM powers on, (all 3 lights ABC) then A and C flash as gyros initialise.

Blue LED stable once GPS Locked
Yellow, is on constantly
Red, does not light up at all.

However, in MP which I connect over telemetry radio. shows data correctly. HUD, radio, mode etc

completed initial set up , radio, compass, level.

Radio seems to be working as expected, on screen and servo movement.

This is the strange thing. MP shows APM arms even without moving rudder from centre, plus its impossible to disarm APM. Rudder or via MP “disarm” button

Also i’ve not seen the Yellow LED lit up before, but maybe its different between arducopter/arduplane?

Ive removed MP from computer, reinstalled it, reflashed the APM with firmware but getting same result.

This APM has worked on previous model with Arducopter, using the same RX and UBEC.

Im now at a loss as to what to try next, so any guidance will be gratefully received.

This wiki link might help:
If you still have a problem, you should post on the DIY Drones website:

Hi Drubug,
APM:Plane doesn’t use transmitter based arming. The reason for that is that zero throttle and full rudder input is normal flight control for some types of flying (eg. deliberatly putting the plane in a spin).
On the PX4 there is a arming switch, but for APM2 you should consider the plane armed whenever the battery is connected.
Cheers, Tridge