Strange airspeed data and strange ArduPlane response

I am trying the ArduSoar with my glider. I use a pitot-static airspeed sensor.
But this sensor displays some strange data. Please look at the attached log data.

First, the airspeed data occasionally fall down to near zero, well below the stall speed of my glider, nevertheless, my glider continues flight. This is the strange point No.1.

Second, The RCOUT C2(elevator channel) does not respond to this airspeed drops. As I set the TECS_SPDWEIGHT parameter to 2, ArduPlane should respond to this airspeed drop and should activate the elevator. This is the strange point No.2.

What is the reason of these strange phenomena?

Those fluctuations look pretty wild if the plane is flying along reasonably level. How did you mount the pitot tube? Did you perform ARSPD_AUTOCAL?

A link to a log file would be helpful


Allister, Thank you for your comment.
I installed the pitot-static tube at the port of the fuselage near the cockpit.

It has 3cm distance from the canopy.
I performed ARSPD_AUTOCAL and set ARSPD_RATIO to 1.9.

I would have said 3 cm should be enough. I’m assuming this plane hasn’t been converted to a motor glider, and there is nothing in front of the canopy.

Did you perform the pre-flight calibration?

When the airspeed was dropping or going low where you in a turn or was there any additional yaw? I’m just taking a shot in the dark here but maybe the pitot tube was being “blanked” by the fuselage.

I agree with Rolf, Flight logs would help.

Thaks Allister,
My glider has a foldable propeller. This is the over all view of the glider.

I want to show you the flight log but I don’t know how I can post it. It was refused because of its big size. Could you teach me?

Checking the flight log, I found the side slip angles are so big (+20deg to -20deg) and the airspeed data drop down when the glider slips right. I also found the big side slip is caused because there is big roll to yaw mixig by the parameter KFF_RDDRMIX which introduced the dutch roll oscillation. So I tried to set KFF_RDDMIX=0 and flight tested again. The side slip angle redused to half and the airspeed drop chance was also redused. But still it exsist.
This is the original flight log.

And this is the log for KFF_RDDMIX=0

I wonder why side slip angle is so big even after I set KFF_RDDMIX=0 .

You need to use a cloud service. Popular one like Google Drive and DropBox are commonly used. I use Then share a link to the file.

Also, can you confirm you have ARSPD_USE = 2?

Thanks Allister,
Yes I set ARSPD_USE=2.

Below is the log file. I hope you can open it.

Those peak airspeeds you noticed (30+m/s) are all when you have the throttle on. Even though ARSPD_USE=2, the pitot tube is still reading. The synthetic airspeed (CTUN.Aspd) at those times is much more under control. So that’s not a problem.

The second spikes in airspeed coincide with significant pitch changes.

The pitch oscillations were getting significant enough that at one point the plane looks like it stalled several times. The controller was holding the nose up even though the airspeed was dropping and eventually the plane stalls. You have TECS_SPDWEIGHT set to 2, but for some reason it doesn’t look like it was prioritizing airspeed as I expected it would.

I’ve never setup a glider so hopefully someone else can jump in here.

Thank you Allister for your kindness.
I will try to understand these data once again.
By the way what program do you use for log analysis? It looks nice!

APM Planner 2 on a mac.

i am also interested in ardusoar and i am trying ardupilot for the first time. I can not find SOAR_ENABLE setting under params. do I need a specific version or fork of Arduplane ??

Looking at the wiki it goes back to at least 3.9. What version are you running?

Edit: I forgot that some boards aren’t able to run Soar. Check this list to see if your board is on here:

I find that layout setting was the problem. Basic/advanced.

Version 4.0.9 on Matek F765