Still problems with RM3100 and 4.0.3?

I have a RM3100 installed on a quad with 4.0.3 stable on it. Compass bitmask is configured to load only RM3100 driver, compass is on external i2c alone, with nothing else connected to that port. All of this on a black cube.
Under hardware i can see the RM3100 but i get constant compass bad health and nothing comes out of it. When i first installed it, it worked with no problems, i rebooted a couple of times after calibration and made a couple of flights. That was yesterday, today i had to fly for a job we got and no matter what, i always get bad compass health and mx, mz, my stay at zero.
I know @tridge has made some mods to the driver but, honestly, i lost track of it and i don’t know if 4.0.3 supports RM3100 or there are still probs.
I tried to add some delay to the board boot, but nothing changed (5000 ms).
The RM3100 that is not working is a new unit we got yesterday because the old one on the quad was doing the same exact thing and we tought it was defective.
So to recap, basicly it installed and calibrated no prob but after 4-5 reboots it stops responding and still shows under hardware in MP, but calibration doesn’t start anymore.

Any reason why you aren’t using 4.0.4-rc2?
AFAIK it has been fixed there.

Just tested on 4.0.4 rc2 same problem. I am using external i2c port, i’ll try to power the module from a 5v power source and see if it makes any difference.


Good day, using rm3100 by drotek?
I’ve three rm3100 and run perfectly on 4.0.3.
i will test it on 4…0.4 rc2…