Still having startup issues


I am having problems arming my quad. I am using APM planner with a Turnigy transmitter with er9X firmware installed. I reset the ESEs and all of the motors powered up. I can configure and save but I cannot arm the copter have used throttle down and direction to the right for 5-8 seconds with no reaction from the copter which has red arming led flashing. On the flight data tab I am getting telemetry and the compass is responsive. Thanks for any help.

In the Flight Data page then down to ‘messages’ what does it say? That might give you some idea why it’s not arming.

Attached is a screen shot of the message screen after I tried to arm button on the actions tab. Trying to arm with the transmitter did nothing with nether method arming the quad. I am getting what seems like the correct feed back from APM ground station, when throttle goes up the graphic in the software goes up etc. etc. Not really sure what to do and I am getting pretty frustrated. This is my first build of a Quad and I am really not sure what to do with this problem. Thanks!


The image doesn’t seem to show the mode switch on channel 5 is calibrated.
The command is received SUCCESS means the command is received. It does not mean the action will complete with success.

Can you post a log (dataflash, or tlog)


Thanks Bill for your response. I am thinking it might be the firmware on my transmitter and I am currently working on getting it reflashed and configured. I will report back here when I am done as to the results.



I have been having similar issues with my X8 operating a Pixhawk on APM Planner v2.0.14 using a Spektrum DX7s. From what I can tell is that everything passes the pre arm test but will not arm the motors once I try and do so.
I will post what I am seeing on the message tab once it connects to copter.

[MAV 001:1] Calibrating barometer
[MAV 001:1] barometer calibration complete
[MAV 001:1] Initialising APM…
[MAV 001:1] ArduCopter V3.1.5 (ee63c88b)
[MAV 001:1] PX4: 9eb74dea NuttX: 65cd7f85
[MAV 001:1] PX4v2 30002000 0C473234 33353231

Hopefully I can resolve the issue tonight. Just updated the TX

Thanks ahead of time

I just wanted to put this information wherever someone like myself would look to resolve a similar problem.

I have been fighting a problem all weekend on a new build where the transmitter would not are the ESCs however the APM 2.6 would arm them. I found several problem that would possibly cause this however each time that I corrected one and then tried to arm, nothing had changed. About to pull my hair out when I saw an action in MP hidden in a drop down that said PRE-Flight calibration. Oh well I might as well I pushed it and I am not even sure that there was any confirmation that it had been done. Next try at arming (#4,322) I almost came out of the chair and ask the wife “What Is That Noise” aah the motors were spinning.

I must say I have not read 1 iota about this in all of the many threads that I have scoured looking for the answer. The one prerequisite is that all of the other pilot errors have to be cleared first which I had my share.

Now my question is how would I accomplish this in the field with just a transmitter in my hand and no connection to MP?