Servers by jDrones

Steering in Acro works fine but in Auto it drives away from waypoints

Hi All,

Since last week, I have the new CUAV X7 with Neo V3 Pro on my rc car.
I took me a few days to get the GPS working and tuning some parameters (mostly for limiting throttle of this 60kmh rc car and tuning steering). Currently it is driving quite good in acro mode.

When I save a waypoint in manual or acro mode and (after driving it a few meters away from this waypoint) put the vehicle in Auto mode, it won’t drive towards the waypoint, but it drives ‘perfectly’ away from is.

The only strange thing I’ve been able to discover so far is during tuning, the desired and achieved steering data are inverted related to each other. I have tried to solve this by enebling RC1_Reverse and turned the board orientation to 180deg, but this doesn’t help (it makes it even worse because acro stops working properly either).

Is there anyone who has the same experience and has successfully solved this problem?
I have added some attachments of my parameters and image of tuning.

Kind regards,
Koen


Randy solved what sounds similar.

1 Like

Thanks for your quick response @Webillo!
I have to say, the story looks mostly the same and so very promising!
To be on the safe side, I will switch off the internal compass too. I already have positioned the external compass (in the gps module) as far in front as possible (far away from the magical engine).

So inverting the parameters RC1_REVERSED and SERVO1_REVERSED might fix our issue?
I will get back to you soon :slight_smile:

Yes Webillo has provided a good link. Here on the wiki we have advice on using the motor test feature in MP.

1 Like

@Webillo and @rmackay9, you were right, the rover was steering to the left in stead during the ‘Motor Test’. I have reversed both variables as mentioned in my previous post.

Guess what… it works now! Youtube video
(I even did forget about disabling the internal Compass, so this was not the problem)

Thank you! :slight_smile:

1 Like

excellent, looking good!

See this. Even the car is positioned opposite to first waypoint, it correctly reorients thanks to compasses, even after a complete reset.

There can be compass arming problems depending on the rotor position (it is a strong magnet). So I permit arming even with compass problems. Later, it seems that motor magnetism is filtered and has no influence. I do compass calibration without the motor; an alternative can be have motor rotating while calibrating with a servo tester.

RTK is used for those laps.

Servers by jDrones