Servers by jDrones

Stat_runtime driving me crazy [SOLVED]

I have a raspberry connected to my cube on telem2 and an herelink connected to telem1.
On the raspberry i have mavlink-router.
If i start the drone without switching on the herelink i can connect to the raspberry mavlink router without any prob in tcp.
As soon as i start herelink and connect to the drone with qgroundcontrol, there is no way for me to connect from my pc to the raspberry mavlink-router using tcp, it stays forever on stat-runtime.

It looks like if i connect with qgroundcontrol from herelink first, than it locks up and doesn’t let me connect to raspberry mavlink-router anymore.

Any help would be greatly appreciated.

Random guess - mavlink1 vs mavlink2. Try forcing one or the other on the
link (beware you may need a recovery option e.g. second telemetry link if
this doesn’t go well.).

Both ports on the cube are mavlink2 (the one connected to herelink and the one connected to the raspberry.
Mavlink router should be agnostic on the mavlink type.
Note that i can connect to mavlink-router in tcp without any prob, untill i start herelink, the moment herelink establishes a connection than it is impossible for me to connect from my pc to the rspberry mavlink-router in tcp, actually i see the telemetry coming but stat_runtime stays forever and once it times out than i can’t see anymore telemetry.

And if you reverse the order ? Connect first from the mavlink-router then start Qgcs and connect via herelink ?

If i first connect to mavlink-router than herelink, it works. But if herelink connects first than i can even switch off herelink but i can’t connect anymore.

Corrado

OK, then ruling out QGCS issue, did you tried use Mission Planner via the herelink as well (no Qgcs) ?

No, didn’t try MP on herelink yet. Will try and see if anything changes. But i would like to use QGC on herelink since it is the one customized for it.

Thank you.

Other idea is to try mavproxy instead of mavlink-router. My guess is that in this particular case you have two routers in the system (one is the flight controller itself) and this causing the issue.

will try mavproxy, thanks.

confirm what gcs id you are using on the pi as well. if there are two nodes on the network with the same sysid on different comport… odd things could happen

default id on herelink QGC and default on PC MP, i guess they are different.

AFAIK both are 255.


image

Changed MP now to 222 and will see if it makes any difference.

thanks

It was the id. Changed to 222 on MP and everything works. Don’t know why but i tought MP and QGC had 2 different default id.

Thanks!!

Corrado

Servers by jDrones