Starting compass calibration does nothing

am not sure whats going on, in a couple PCs and using latest and beta versions of MP I cant start compass calibration…I click on the start button but nothing happens, the green bars dont show any progress…any clues?

ensure you are disarmed

Good day, what kind of tc and gps do you have?
on MP you have enable all the compasses?

I had the same problem with the Matek F65-wing FC. It turned out that I had a bad connection in one of the GPS cables.

Check if any GPS is detected, that was the key for me. After fixing the cable everything works as it should.


I am having the same problem - compass calibration will not start (no green bars, text box showing progress). Pixhawk Cube orange plus Here3 GPS. My colleague’s PC works just fine (i.e. calibration starts), so I know it is not an aircraft configuration issue. This process worked just fine until recently and I am not sure what (changed to prevent this).

Aircraft is disarmed. I have a GPS lock. I tried uninstalling/reinstalling to fix any MissionPlanner issues.

Pixhawk Firmware V4.1.2 (20416b38)
MissionPlanner was uninstalled/reinstalled this morning (12/20/2021). trying beta now.