Servers by jDrones

Start Mission from QGC


(Justin) #1

Hello All,

I’m new and am trying to understand how to start a mission. I created a flight plan, sent to vehicle, and verified that it was uploaded. I then switch to auto mode and my copter goes straight up. I’ve tried Mission Planner and this process seems to work, but not with QGC. I read through the ArduPilot and QGC guide, but they both stop at “load flight plan”. What am I doing wrong?


(DonLakeFlyer) #2

If the vehicle goes straight up then something is wrong with the mission you created. There is no real difference between running a mission in Mission Planner or QGC. Can you attach the mission here?


(Justin) #3

I managed to get it to work this weekend, but not as desired. QGC automatically adds the Takeoff waypoint to the beginning of the mission. When I removed Takeoff, auto mode would initiate the mission. I also had similar issues with Loiter (turns). The drone would reach these Loiter (turns) waypoints and would not sequence until I toggled out of auto and back in to auto. With normal waypoints, I had no issues.
This site will not allow a .mission file type upload, so I took a screenshot. Is there another way to upload the mission?


(DonLakeFlyer) #4

If the mission itself is not working correctly then that is more of a firmware problem than a ground station problem. You can attach the mission here by adding .txt to the end of the file name. If you attach I can give it a try.


(Justin) #5

UW 1.txt (2.7 KB)
Thank you!


(DonLakeFlyer) #6

I just ran your mission through SITL ArduCopter using latest master builds and it worked fine. When you say “it does no sequence” what do you mean? It gets stuck doing more loiter turns than you specified?


(Justin) #7

Don, I’ve tried and tried to get this to auto sequence, but it still does not. I’ve built flight plans in QGC & MP and both provide the same results in flight. The “autoContinue” parameter in the mission file definitely says “true”. What actually happens when I enter “Auto” mode is the copter flies to the Loiter (turns) waypoint, but then sits at the point and does nothing. When I flip out of Auto and then reengage Auto, the copter spins the appropriate number of times/radius and continues to the next waypoint where it again waits until I disengage/reengage. Normal waypoints will auto sequence just fine. I need to create an entire survey of Loiter (turns) waypoints. I can’t expect the user to disengage/reengage repeatedly.


(DonLakeFlyer) #8

I though you said it work with Mission Planner but didn’t work with QGC? If it doess’t work with both then it’s some sort of firmware issue not a ground station issue.


(Justin) #9

I originally had multiple issues (this is my first drone). I was unsure if it was all related to user error, so I posted in one thread. When I create a mission in MP consisting of only basic waypoints, auto mode works. When I create a basic waypoint mission in QGC, auto mode does not work. QGC missions will work in auto after I delete the “takeoff” that QGC automatically inserts into the beginning of the mission. It is the least concerning of the problems I have. I can try to take some video this weekend to demonstrate the issues I am having, would that help? Also, should I create a new thread tagged in firmware and bother some new people about the specific Loiter (turns) problem?


(DonLakeFlyer) #10

Yes. That seems like a firmware problem.