Servers by jDrones

Stall speed and landing in FBWA

landing
pixhawk21
arduplane
stall

(Tim Squires) #1

Hi,

I had two stalls on two different planes (big A tail and Skywalker X5) while they were running Auto missions. They both stalled on a sharp turn, last-but-one waypoint on different days and in different wind conditions.

I increased the ARSP_FBW_MIN and TRIM_ARSP_CM by 3m/s and ran the same mission to test. All went fine with take-off, mission and landing perfect.

Unfortunately, now when I land the A tail using FBWA, the airspeed drops below the 12m/s and the stall prevention kicks in dropping the nose - into the ground!

I know FBWA has enhanced stall prevention so my questions are:
Should FBWA be avoided for landing?
Are there other settings that would allow low risk landing on FBWA?
Other than Manual and Auto, what modes are recommend for landing?
Can I go back to -3m/s but increase the turn speed so it does not stall?

ArduPlane 3.8.2 on Pixhawk 2.1 with Here+. I’ll dig out the logs if helpful.

Thanks, Tim


(Kikislater) #2

Why not using FBWB in that case ? It maintain speed with trottle control whereas fbwa doesn’t control throttle.
RTL have an option to autoland. Watch here :
http://ardupilot.org/plane/docs/parameters.html#rtl-autoland-rtl-auto-land

RTL_AUTOLAND: RTL auto land
Automatically begin landing sequence after arriving at RTL location. This requires the addition of a DO_LAND_START mission item, which acts as a marker for the start of a landing sequence. The closest landing sequence will be chosen to the current location.
Values
Value Meaning
0 Disable
1 Enable - go HOME then land
2 Enable - go directly to landing sequence


(Tim Squires) #3

Thanks kikislater. I often use RTL as a last point in the mission before uploading a new mission without landing. More efficient to loiter above home point and than land and take-off again but it’s is a good idea, thanks. :slight_smile:

I’ll practice on FBWB/Cruise to see how it lands at ARSP_FWB_MIN for each plane. 12m/s may be a bit fast. On another plane (FX-79) I land on FBWA with flaps down, well below the ARSP_FWB_MIN - nice and slow.


(Kikislater) #4

I read that skywalker x5 has a high stall speed


(Tim Squires) #5

Yeah, the MIN is set to 13m/s and the TRIM_ARSP_CM is set to 1600cm/s. The A tail plane was 8m/s but is now 10m/s. In a straight line, the A Tail plane has a great glide ratio but just that one stall has made me nervous. It’s an expensive aircraft and will not survive a[nother] heavy landing.

The X5 is my prototype plane and has my respect for handling some very heavy landings. I’m currently test dropping it from a octocopter at 100m AGL and it switches from FBWA to Auto to fly home. :smiley:


(Kikislater) #6

:slight_smile:
Do you have a pic or video of this !?


(Tim Squires) #7

Sort of -

No video of the X5 drop yet because errm… well, I forgot to press record on the GoPro on the only time I mounted a camera.

Having issues with the octocopter at the moment because it has a pixhawk 1 with raspberry pi companion. The pi runs dronekit which does a guided take-off to 120m and then lands else-where in the field so it does not land at the same place as the X5. I’ve broken the dronekit script because last time I tried, it armed the motors but did not take-off. Hoping to have time on Saturday to try again.


(Tim Squires) #8

FYI, landing on Cruise mode is fine except when landing site is not exactly at home altitude. In this case, the prop spins, even after the plane has landed. Maybe because the plane is facing the wind and the airspeed is not quite 0.