Stabilize/Acro/Loiter OK but aggressive auto navigation

Experiencing a strange behavior during auto/missions. Each time a waypoint is reached, there is a quite aggressive twitch, even if just a slight turn is needed. First times it resulted in uncontrollable moves and needed to bail out manually. I’m now testing with decreasing the speeds WPNav and Loiter and decreasing the Loiter P and Rate Loiter P.

Quadcopter, 3DR 2014 frame (long middle plate), 700KV motors spinnig 12x3 blades, 3S 5000mAh battery. Is not the lightest, but flightiness easy go in the 15+ minutes.

Attached 2 logfiles and a mission. … 1.bin?dl=0 … .tlog?dl=0 … 2.txt?dl=0

Any suggestion on what to check next?

After hours of finetuning Loiter P, Rate Loiter PID, Speed, Loiter Speed, Speed Up, Speed Down, this is what ended up best. The difference between a Loiter P/Rate Loiter P of 0.5 and 0.4 for example are very noticeable.


All testing so far was done without any wind, so still need to check that a Loiter P/Rate Loiter P of 0.5 or sufficient for a steady Loiter.

Still not convinced this is the way to go, since waypoint actions are still (very) abrupt. Also the Speed Up/Down is lowered, as well as the Speed, otherwise waypoint actions are immediatly even more abrupt

All the roll/pitch values come from AutoTune, and these are good. Quad feels locked, without overshoots in Stabilize, Sport mode and also in Loiter.

Checked for vibrations, all looks ok.

Referenced a log file from yesterday evening, no wind.

Finally a person with my issue! I’m having the same issue after new firmware update. Very fast moving abrupt movements. Or it starts to do a death roll toward the ground slowly clockwise. I have to switch to stabilize and save it here and there cause of it. I never had an issue till new firmware update 3.1 Loiter, stabilize,alt hold,acro and so forth fly perfect. Did every kind of calibration there is. still wont fly good in auto or guided.

Spend some hours tuning the Loiter P and Rate Loiter PID, last weekend. These are the values I use now, tested in some wind (4bft):

Loiter P: 0.200

Rate Loiter P: 0.150
Rate Loiter I: 0.700
Rate Loiter D: 0.000

Speed: 500
Loiter Speed: 1000
Speed Up: 500

These worked out fine.

Need to compare the Loiter mode in heavy wind (4+ bft), not sure that the low P (0.2) keeps it locked in place like the default of 1.0. This default value of 1.0 is OK for Loiter, not for Auto/Guided.

I have a Easy fix for you! After hours of inventing my own dialect out in the workshop it dawned on me firmware 3.1? Lets put an older firmware on it. I have no problems now with guide or auto and everything seems to be working correctly now. I read a few people having this problem online now and I guess it has to do with the way the esc talk to the apm in these two modes

Well I tried the 3.1 firmware one last time! This time it set my throttle to 8 out of 0-1000 on max speed when I redid the firmware. Advanced settings was last one in the list. Anyhow after that I flew it and did a auto tune and tested all the modes. loiter,alt hold, land, rth all worked perfectly once again. Auto and guided failed once again. I looked in the logs and motor 2, 5, 6 lose power in spikes. There is no brown out issue or failing part. I thought it might be vibrations or gps noise. gps noise was like 15-21 and vibrations where so low during the event. Apm unit has perfect power levels and feeding it. 14 sat link

Well I loaded 2.9 firmware a second time today and everything works flawless now once again. So it is something to do with this firmware 100% now. That is where I shall leave it for the simple reason having 4 grand worth or cameras and custom made parts fall out of the sky over new firmware when old works better. :astonished:

Thanks for the info!
Before going to an older FW version I just tried out the 3.2 release. Issue is solved there as well. Smooth transitions again, ‘normal’/closer to default Loiter Pids again. (0.8).

Next up, splines, should make it even smoother. :slight_smile: