SPM4651T with SRXL2

It’ll work with the existing spektrum port however, pixhawk/ardupilot is unable to read the telemetry data via that port. Our plan was to hook it up via RCIN as a serial link. We’re not quite sure if this will work yet.

We’re able to get telemetry data down to the transmitter but we really want it within the ardupilot so it can be logged.

Sorry I wasn’t clear - this will work with the SRXL2 support that is already in master. Get a build of master from the link above, attach the RX to a serial port, select protocol 23 and half-duplex and you should be good to go. Telemetry works - I am using it with my SPM4650. SRXL2 will not work on the RCIN or SPKT ports - you need to use a serial port.

Thank you for the information!

Do you have a wiring diagram I can see? Will need to put on a new connector and having a hard time finding pinouts or examples.

1 Like

I don’t for the cube black I’m afraid. SRXL is a 3-wire protocol. GND-GND, +5v-+5V and SIGNAL-TX
It’s very important that you connect the signal wire to the TX on the serial port as the cube black is an F4 and you can’t switch RX and TX in software. The receiver should come with a pinout - one of the wires is n/c.

We got it up an running!

Question is now, how would we get mission planner to report RSSI data from the receiver?

Channel mapping is working as expected!


More words

So we’re getting some interesting RSSI data. This is the output.

First photo is at full power

And this is reduced power

This is with the transmitter and receiver sitting on the bench next to one another. At the full power setting, the output bounces from 0 to 100.

What’s interesting though, when power is reduced, it bounces from 30 to 95-98.

Is there a setting somewhere that we have wrong?

Interesting. We only report the RSSI that the RX tells us, but I could have screwed up somewhere.

Also please check this https://www.rcgroups.com/forums/showpost.php?p=44329579&postcount=221 as there are clearly some issues with RSSI on some versions of the firmware. Before I start drilling into this are you able to make sure you have the latest?

I’ll see if I can reproduce this with my SPM4650’s

1 Like

Have the latest and greatest. These are US version.

Here’s my RSSI flying round a field:

So what I would expect. So I can’t reproduce your issue, but I guess it might be related to the RX.

That firmware fix was actually for all variants, US also - it describes this later on in the thread. So I encourage you to check and upgrade if you are able - not saying it will fix this, but it’s something we must try.

Here’s a range test. First half is reduced power walking away, second half is full power walking back:

So all working correctly and something wrong with either your setup or firmware.

You are sure you have RSS_TYPE = 3?

How very interesting. We’re very perplexed by this issue. We have set the SERIAL1_OPTIONS to 8 but that corresponds to “swap”. We’ve tried both “HalfDuplex” and “Swap” to no avail. We also updated the 4651T to the latest firmware.

Is there anything else you can recommend that we check or toggle?

This looks relevant


and your description got me thinking, and after some digging I found this:

so I suspect what you are seeing is the switch between dbm and %age and we should do the same as BF and only report the %age value.

Are you able to build firmware? If not I can give you a test to try if you tell me the FC you are using.

This fix is now in master, so you can try it if you load the latest firmware

I am trying to use this same receiver on a Pixhawk 2.1 Blue Cube and can’t seem to get it to connect. I am using Firmware 4.0.5. I have the the signal wire connected to the TX pin on Serial1 and it configed to 23 for RCin and 4 for HalfDuplex.

What am I missing?


Andy, Is this a regular part of the firmware now or do I need to continue using the “Developer” firmware that I received from you?


Also what is your experience on range with this receiver? My RSSI Bars drop out at 1/4 mile. I feel I should get more range. Even though the bars drop out I still had control but I didn’t fly much further out of fear of losing connection.


These have the support: https://firmware.ardupilot.org/Copter/latest/

Not tried range - that particular RX is on my bench