SPLINE_WAYPOINTS missing from Mission Planner

I did a new installation of the latest (v 1.3.28) MP on a PC and SPLINE_WAYPOINT isn’t listed in the command drop down list. Further, if I check the Spline box before clicking on the map, it drops a waypoint at 0,0 Lat/Long.

The first installation was on a Windows 7 machine. I subsequently tried it on another 7, then on a Windows 10 technical preview PC. They all behave the same.

This only seems to happen on fresh installations. I use two Windows 7 laptops for flying and they were both updated from previous versions and work fine.

Wondering if anyone else has encountered this or has a solution.

I observe the same thing. Very frustrating!

Have you tried in the latest version of mp 1.3.30?

Apparently nothing is wrong with it. It’s default for airplane mode which doesn’t have spline waypoints. I found that by opening a telemetry log of the appropriate aircraft, it switches mode. It takes on whatever mode the flight controller is in of course, but I didn’t think to do that.

I downloaded flight logs from droneshare.com and was able to switch it between airplane and multicopter modes.