Spinning after takeoff on 3" drone

Hello everyone,

So I’ve finished building a 3" drone equipped with Matek H743 slim, hereflow, range sensor and a GM10 flywoo nano GPS w/ compass.

I followed amilcarlucas amazing guide on how to tune it, I reached a point where I need to test it in stabilize mode.

So I slapped the batteries on and I took off, but it spins to the right everytime, it’s impossible to fly, on every takeoff it just keeps spinning to the right, starts slow then goes a little faster.

I thought it was the compass so I did a motor/compass calibration (the one which you need when you have vibrations), calibrated the compass, put it on a little mast but nothing seems to help.

Yesterday it flew once but today it’s not really working.

I tried looking into the log file but I really have no idea where or what to look at, could anyone help please?
3 01-1-1980 2-00-00 AM.bin (1004 KB)

You’ve disabled arming checks. (don’t do that, it’s only asking for trouble)

There’s no GPS lock.

If you moved the compass to put it on a mast, you will need to re-calibrate it. The compass is getting a lot of interference so that’s not helping. You might need to try in a different location.

1 Like

I’m flying indoor so there’s no GPS, I even disconnected it as it’s not needed I only need the compass.
I re-calibrated the compass, the drone is tiny so I’m not sure if i can get it any further, it’s kinda hard mounted could that be the reason?

Try it outside with the GPS and see if the problem goes away.

1 Like

But stabilize mode shouldn’t depend on compass right?
I disabled the compass and the issue was still there.

I connected the GPS again and tried outside but it’s still spinning

1 Like

Hi what esc are you using is it a 4 in 1 connected the way they mark it if so try going to frame type and setting it to Beta Flight X hope this solves your problem good flying


I looked at your log and you have a SEVERE yaw imbalance

Motors 3 and 4 (the clockwise spinning motors) are spinning ~10k RPM faster than the other two, but that isn’t enough to stabilize the yaw axis.

[Edit] Check the Motor order and direction as Marty suggested, more information here: Connect ESCs and Motors — Copter documentation


It is a 4in1 esc from the HGLRC FD435 stack, it is connected correctly, running dshot600, I will try the betaflight FRAME_TYPE in a few. Thanks

Here’s a log with the GPS and compass completely disconnected:

1 Like

I don’t think betaflight will help. Since the copter didn’t try to flip I’d think the motor order is correct.

But try it anyway, just tie it down so it can’t flip and destroy itself (especially the GPS mast is in danger)


Jan,when I built my tay can I had the 4 in 1 esc wired for betaflight,but the motor directions were all correct eg front left one was anti clockwise and back left one clockwise and it id not try and flip but controls were wrong and im sure it wanted to rotate


So I just changed FRAME_TYPE=12 (betaflight x) and it tried to flip twice so it’s probably something else

I want to add that I did manage to fly once before on FRAME_TYPE=1.

Here’s how I have my motors props connected:

Front right: CCW (A)
Bottom right: CW (B)
Bottom left: CCW (C)
Front left: CW (D)

The letters ABCD are from the mission planner motor test section

Here’s the log of the last flight (almost flipping on takeoff twice)

1 Like

O im sorry thought it would help

1 Like

It’s alright it’s no big deal it’s a tiny quad even if it flips it hardly takes any damage, appreciate the help :pray:

a closeup of the quad:

1 Like

This time motor 1 and 4 were spinning higher than 2 and 3. In the betaflight configuration motors 1 and 4 are again the two CW spinning motors, meaning the FC tried to balance a yaw to the right. In the default configuration motors 1 and 4 are on the same side though, so this time it tried to flip.

Did you check the motor direction on this Mission Planner page?

If all motors are spinning the wrong way, try ‘Quad H’ (FRAME_TYPE = 3).
If all motors are spinning the correct way, you have a physical problem, i.e. that the motors are not mounted in one plane but are skewed relative to another.

[Edit] looking at the now included pictures, Quad X is definitely correct

Yes here’s what I have:

1 Like

Ah yes, I didn’t see that [edited info] before posting my answer^^

Given every information I’d go for skewed motor mounts as source of the problem.

1 Like

O that is beautiful love it I am now only doing small craft my 3 incher flew away back to china lol so now working on a 4 incher and a small VTOL

1 Like

I designed the frame myself and I’m no expert so this might actually be true but here’s how I designed it:

…[D] <— 96mm —>[A]
… |------------------------|
… |------------------------|
… [C] <— 96mm —>[B]

I know it’s not clear sorry I tried my best drawing it :sweat_smile:

It’s printed with PLA+, I added additional motor mounts to keep the blades from hitting any of the components, so the only thing to try right now is either removing or replacing the motor mounts right?

What I really still don’t understand is how it did manage to fly smoothly yesterday for like 3-4 minutes, maybe having PLA+ frame makes it inconsistent?


What a great catch!!
I removed the motor mount extensions and it’s now flying smoothly!!

Thank you guys so much for helping :pray: :pray: :pray:


Great to hear :smile: :+1:

1 Like