Spent an hour tuning roll and pitch P's today

Okay guys- first off I’m new to the APM world but have been flying RC planes for 10 years.

I’ve got a 54 inch wing that I have put APM 2.5 in, along with the ublox GPS, airspeed sensor, and after today, the telemetry is on order.

I did a lot of reading, and ended up setting up 3 flight modes: manual, FBWA, and RTL. I only experimented with manual and FBWA today.

The only tuning I’ve done- I increased the P’s on both pitch and roll until I got oscillaiton (SCARY), then reduced the P’s by about 1/3rd.

The plane is flying smoothly in FBWA now, BUT here are my two issues:
-the roll- the plane doesn’t roll very far in either direction, and although it is crisp and returns to level flight quickly without overshooting, the roll angle is so low that any turning in FBWA is going to take hundreds of yards to accomplish. Right now FBWA mode is worthless because turning takes forever.

-the pitch- the plane doesn’t respond to pitch inputs nearly at all. When I turned up the pitch P, I would get porpoising. When I turn it down, I get straight and level flight but I can’t control the pitch?

I turned on logs before flying, so I think I should have those if need be. Thanks for any insight…

It sounds like you have LIM_ROLL_CD too small. The default is 4500 (which is 45 degrees). The right value depends on your aircraft and what G forces it can sustain. For an aerobatic plane a value of 6000 or 6500 is often good.
As always, logs would help determine if this guess is right :slight_smile:


With all due respect Tridge, and me admitting that I have no idea what is going on with and between these parameters, how is adjusting the roll limitation going to affect the absolute lack of pitch control that I’m experiencing? :neutral_face: I will admit I think my airspeed sensor was not calibrated last weekend- can that cause pitch control irresponsiveness?.. I guess I just want to reiterate that the main problem is that I can’t “pull up”- the wing literally does not respond to elevator inputs. it just remains somewhat level, descending ever so slightly.

The turning is very lax- but definitely not my main problem currently. Look forward to hearing from you friend.


What about adjusting the pitch limits?

The LIM_ROLL_CD, if I remember correctly from the manual, should be the roll angle that FBW_A maintains. You’re limiting the roll limit with that so you should see it turn around faster that way.

After checking the LIM_ROLL_CD, check if your radio calibration is OK. One time my plane woudn’t roll enough for turning on FBWA, then I noticed I had the dual rates on. No wonder it wouldn’t roll enough.
Regarding to pitch, you have to check the TECS parameters. For a quick try: set the airspeed sensor to not be used (although enabled). If you have TECS parameters problems comming to pitch, disabilig the USE of the airspeed sensor should solve your problem. I assume you have enough limits on both ROLL and PITCH.