Spektrum SRXL2 connection problem (AR6610T + SPM4651T)

Hi all, this is my first post so apologies if there are issues with formatting/location/etc.

  • Summary/Problem: I am having trouble getting radio input from my Spektrum SRXL2 receiver. There are no green bars in the radio calibration menu of mission planner.

  • Software: Plane 4.1.4 and plane 4.1.5 (I started on 4.1.4, and am now on 4.1.5–same results with both)

  • Hardware: Spektrum AR6610T with SPM4651T satellite, Spektrum NX8 transmitter, Pixhawk 2.1 orange cube

  • Hardware hookup: SPM4651T → 4pin SRXL2 port on the AR6610T (for diversity), AR6610T bind/prog/SRXL2 port out to pixhawk: grounded and power supplied via rc out rail, rx signal/srxl2 wire to GPS2 (serial 4) TX pin. I have also tried GPS1 (serial 3) on the pixhawk

  • Software parameter changes (X = 3 or 4, I have tried both serial ports):

  1. SERIALX_OPTIONS = 4 (half-duplex)
  2. SERIALX_BAUD = 115
  3. SERIALX_PROTOCOL = 23 (rc input)
  4. RSSI_TYPE = 3 (receiver protocol)
  5. RC_PROTOCOLS = 256 (srxl2)
  • What I know works:
  1. Receiver is properly bound to transmitter: solid lights on rx/satellite and positive servo control when powered from external power supply. This was verified independent from the pixhawk, but the rx lights remain on and bound when hooked up to the pixhawk
  2. Pixhawk works and has flown with spektrum dsmx receiver
  3. Pixhawk pinouts for tx pin on GPS1 and GPS2 found here: d1159ae11c769742a9824ebf57131bf0e30db724.png (1224×1584) (ardupilot.org)
  • What I have tried and didn’t work:
  1. I read that there might be problems with the rx firmware not liking radios with more than 6 channels, so I also repeated all of my tests with a Dx6 radio to no avail
  2. I have tried both Plane 4.1.4 and 4.1.5
  3. I have tested on two separate pixhawk cube oranges
  4. I have tried both serial4 (GPS2) and serial3 (GPS1). At some point I think I even tried the telem 2 port
  5. I have tried the AR6610T without the SPM4651T satellite connected
  6. I have tried powering the pixhawk/rx first, then the transmitter
  • What I think might be a problem / haven’t tried
  1. Receiver firmware update: I am not paying $40 for the spektrum receiver cable to flash new firmware. Anyone know what the wiring is on that so I can solder up my own with an old FTDI cable? Anyways, why the heck would spektrum be shipping receivers without current firmware???
  2. I have not tried just the SPM4651T satellite on its own–though I have seen others have success with this rx. But the entire reason I purchased the AR6610T and SPM4651T was to increase range and have diversity… EDIT: have tried this and the satellite rx on its own works.

Please let me know if there is any information I am missing in my post and I will update it accordingly. I appreciate any and all insight! This has been very frustrating

UPDATE: SPM4651T satellite works when connected on its own, i.e. no AR6610T present. But I still need the full range receiver. Grrrr…

UPDATE: AR6610T works when connected through the 4-pin SRXL2 port (the port the satellite was originally connected to) but NOT the 3-pin bind/prog/SRXL2 port. But after power up through the 4-pin SRXL2 connector and swapping to the 3-pin port, it works. So the problem has been narrowed down to a power-up issue with it initially connected to the pixhawk through the 3-pin rx SRXL2 port on the AR6610T.

Current workaround is: power up pixhawk with AR6610T connected through 4-pin SRXL2 output, verify radio connection in mission planner, swap AR6610T connection to 3-pin connector on servo rail, and plug in satellite to 4-pin SRXL2 port. Rebooting the pixhawk via mission planner results in no radio connection again…

Anyone know what is going on with the communication not initializing over the 3-pin bind/prog/srxl2 port on the AR6610T?

This sounds like a “listen-only” receiver: Support SRXL2 listen-only devices by andyp1per · Pull Request #14341 · ArduPilot/ardupilot · GitHub - it does require that transmitter is powered after the receiver, but I have only tried this on the AR610, so difficult to tell if its the same issue. The fact that the remote works otherwise shows that everything else is working.

This is exactly my issue! Did you get a solution? Where did you get the correct cable to connect the 4-pin connection to the pixhawk?

The only solution was to power/connect the main rx via the 4pin satellite port, boot pixhawk and verify radio connection, swap to 3-pin srxl port on the main and plug satellite into 4-pin sat port. This needs to be done for every power up. Still not sure if the satellite is actually doing anything after all this swapping…
The issue is that the ‘handshake’ through srxl2 is slightly different depending on if you connect through the main srxl2 port or satellite port (I mostly blame spektrum). Ardupilot is only currently capable of handling the satellite handshake.

I soldered a spare spektrum satellite cable to a spare pixhawk telem cable

From Spektrum - “if they want to use redundant RF via a remote, I’d recommend connecting the remote to the 4-pin port, and connect the Pixhawk to port 1 (throttle), not the Bind/Prog/Srxl2 port. This is assuming that Ardupilot supports talking first to the AR6610T to initiate the handshake process, which it sounded like you were planning to add. That configuration puts the 4651T on its own dedicated SRXL2 bus, and puts the pixhawk on the AR6610T’s other SRXL2 bus. The dual receiver configuration works best when the AR6610T can aggregate the data from the remote and send it out to the pixhawk on a separate port, and the throttle port functions as SRXL2 as long as it is sent an SRXL2 packet within 250ms of startup, or before RF is connected (i.e. before the transmitter is turned on). I don’t suspect the latest firmware updates would even be required for this solution, unless they have really old receivers.

We do support this bootstrap mechanism (you need to set RC_PROTOCOLS) so worth a try