Spektrum satellite receiver not working with omnibus F4 pro

I want to use this spektrum satellite reciever with this Omnibus F4 pro v3

(Both flight controllers have the latest arduplane 3.9.9 OFFICIAL firmware installed)

When I first connected the reciever and tried to bind it using the spektrum bind buttons in mission planner, nothing happened. I also tried connecting the receiver to my pixhawk and tried binding. Again, nothing happened. After many hours of searching the internet for a solution(and not finding it). I decided to upload betaflight firmware onto the F4 pro and tried binding the receiver by using the CLI in betaflight configurator. It worked flawlessly! All channels where recieved properly and shown in betaflight configurator. Then I uploaded the arduplane firmware again. It still didn’t respond to the reciever, no channels recieved. Then I connected the reciever to my pixhawk again, It now did receive all channels properly.

So there are two problems:

  1. Satellite reciever cannot be put into binding mode by pixhawk
  2. Satellite reciever does seem to communicate at all with F4 pro

These must be pure software problems as everyting works fine with the betaflight firmware.

Please tell me if there is anything I can try because, if I can’t get ardupilot to work with this hardware I will have to start using betaflight.


Like instructed under “versions” The SBUS/PPM jumper was soldered to PPM from the beginning.

So apperently it does work when the signal wire from the reciever is connected to J7(PPM SBUS) instead of J8 DSM2. It is very inconvenient this way because I had to cut the wire and solder a female pin header to it. This would not have been necessary if the J8 DSM2 input was implemented in the firmware. I hope this is a planned feature.

F4 pro Pinout

Hi, I am having the exact same problem right now, trying to connect the same Redcon receiver to an Omnibus F4 Pro but using Betaflight.
I connected the receiver via the JST-Connector to the DSM2 port next to the USB-Port.
I could bind it to my transmitter (the Receiver has a solid orange light and my DX7s says “DSMX” in the top tight corner), but the channels in the receiver tab aren’t moving.

It did work in Betaflight for you like that, right? Could you please tell me the settings you used, that’d be awesome.

I enabled Serial RX on Port UART1 in the Ports tab and chose “Speksat” and “SPEKTRUM2048” in the Config tab, but I can’t see anything moving in the receiver tab.

Hi Joel,
I followed This Totorial. I can’t remember wich UART port worked for me, so I guess you should try all three.
Did you bind the reciever by entering set spektrum_sat_bind = 9 in the CLI? If so that proves that there is a working serial connection to the reciever. I wouln’t know why it doesn’t get the channel data.

Just out of curyosity, why do want to use betaflight instead of ardupilot?

1 Like

Hi, thanks for the link and the answer. UART1 is the only one that works, this fits the information I find elsewhere on the web.
Yes, I used the CLI, however the binding process only works with values 1,2,3,5,6,7, but not with 9, 8, 4 or 0. I can’t figure out why. Do I need to change the settings on my Spektrum transmitter?

I am using Betaflight since this is a FPV Quadcopter/Racer and the OSD config menu is quite nice, but I use Ardupilot for my larger builds/LOS-Only Copters.

set spektrum_sat_bind = 9 worked fine for me.
I don’t think it has anything to do with the transmitter. If the Orange light on the reciever is solid when the transmitter is on, it is recieving correctly.

Maybe you should ask this question on the betaflight forum instead.

A lot of time has passed since the last post here, but I think this is still a current issue.
Like many others among us, I was troubled by the problem of how to connect Spektrum Satellite to FC Omnibus F4 V3 controller.
I believe this solution will be good also for other similar Omnibus FC-s.

My starting situation was as follows:

  • I managed to connect the FC omnibus to Mission Planner (1.3.74), via USB port.
  • In the J8 socket (3 poles, 3.3V), next to the USB socket, I plugged in a 3-pole cable that connects the Spektrum satellite receiver
    (Satellite Receiver has previously been paired with a transmitter, using another standard DSMX receiver)
  • in Mission Planner there was no movement of radio commands from the RC transmitter and that was a problem I needed to solve.

I made:

  • In Mission Planner, I set the Config->Planner->Layout:Advanced option. This is required for Config->FullParameterList to appear in the Mission Planner Config menu.
  • I opened the Full Parameter List and set:
    SERIAL1_BAUD 115
    and then:
    Write Params

Then I did the following:

  • Mission Planner - Disconnect
  • I switched off Omnibus FC USB cable
  • I turned on the RC transmitter
  • I plugged in the USB cable again. The orange LED on the Satellite receiver was ON.

After that in Mission Planner-Setup->Radio Calibration I saw the movement of all radio channels.
The problem was solved!

Thank you…

1 Like

i did it ,but still cant work.

1000000% correct!!!!!!!!!!!
let me tell u how to do it with satellite, PPM solder pad/resistor should be soldered and “S-BUS” resistor/solder pad removed Otherwise, and them satellite need to soldered at ppm rcin in position, not the satellite position, 3 lines, you need to take the sign line out and solderd at ppm rcin positon. neednt set any thing in ardupolit!