Servers by jDrones

Speed Throttle at Waypoints

(F) #1

Hello everybody,
I am currently planning to build an autonomous boat with a length of 170cm. Unfortunately, I am still a beginner in the field.The boat is steered by a Z-drive, which makes the curves narrower the higher the speed. I have set a cruise speed of 9m/s. My problem now is that the boat throttles the speed at the waypoints to 4m/s. However, it should drive a consistent speed. Is it possible to change this with a parameter or is there another possibility.
Let me know if you need more information.

Thank you in advance for your help!

(rmackay9) #2

@zelos48, It may help to increase the WP_OVERSHOOT parameter. There’s a request on the to-do list to support boats that plane and thus should not reduce speed below the plane speed.

1 Like
(F) #3

Many Thanks. I think I will try it today. Is there already a beta version in which this parameter is already tested?

(F) #4

Changing the parameter did not solve the problem. However, I have found a way how the speed reduction does not occur. I’ve arranged the waypoints so that he only has to deal with obtuse angles. This allowed me to achieve a sustained speed of about 11m / s.

https://www.file-upload.net/download-13633884/log_89_2019-6-13-09-09-44.bin.html

I am grateful for suggestions for improvement

1 Like
(F) #5

Does anyone have an idea how to fix this huge overshoot?
%C3%9CberschwingenA

Here is my parameter list
2019_06_13.param (13.4 KB)

(rmackay9) #6

@zelos48, have you had a chance to turn the steering controller? We’ve got a wiki page here which describes how to tune the steering turn-rate controller.

EDIT: I’ve had a quick look at the log file provided earlier and it looks like the actual turn rate is not keeping up with the desired. This normally means the ATC_STR_RAT_FF is too low (and perhaps P and I are also too low). It looks like the FF has already been increased from the default of 0.2 to 3.0 but it looks like it needs to be a lot larger still… perhaps 9 or 12. that’s very high but from a first look it seems to be necessary.

1 Like
(F) #7

I have already done the tuning steps. I also recognized that the turn rate is too low, but I thought 3.0 is the highest value I can choose. I will try it tomorrow. Thank you very much for your advice.

1 Like
(rmackay9) #8

@zelos48,

It may be necessary to change the parameters (which start with ATC_) directly from the MP’s Full Parameter List or Full Parameter Tree page (assumming you’re using MP).

1 Like
(F) #9

Hi there,
Today I tested again with the increased FF value. In my opinion, the driving behavior is quite neat. Soon I want to increase the speed even further. Now my question is: is it possible to change the cruise speed during a auto mission? Or is it only possible by changing the parameters?
Here is a screenshot of today’s mission:

Best regards

2 Likes
(Reuben Finch) #10

It should be possible to change speed during an AUTO mission using command DO_CHANGE_SPEED. The 1st value is ignored, 2nd should be desired speed in m/s, 3rd in throttle %.

However I’m having issues with this command. Please let me know if it works for you.

1 Like