Servers by jDrones

Spectrum DX8 no connection to Pixhawk2.1

Hi guys, I’m at my wits end trying to get my DX8 gen 2 to communicate with the Pixhawk 2.1 black cube. The bind process works fine, all lights flash rapidly then go solid when bound. There is just no servo movement. I have the Pixhawk connected with the supplied power adapter to a 3 cell lipo and to the computer with the usb cable. Anyone have a similar issue?
Thanks

Have you got it connected to the RCIN and not the SBUS pins?
And tried the radio calibration in MissionPlanner?

If you are a first time user of Ardupilot, be aware fhe servos and outputs wont necessarily respond as you expect, or at all - until the flight controller is armed.

I changed the rate from 22ms to 11ms and for some reason that worked. Thanks to Nathan for going threw my same circumstance and figuring it out.

1 Like

@bnaikelis can you please test this firmware:
http://uav.tridgell.net/tmp/plane-DSM-22ms-test1.apj
that is a CubeBlack build of my fix for the issue:


if it works I will include it in plane 4.0.3

You’ll have to forgive me, I’m new to this type of RC flying/ programming. How do I test it, bind in 22ms and see if it works? I’m headed to work now and can try it when I get home.

Thanks Bobby

yes. You can just load ‘latest’ now as we have merged it into master based on successful testing from another developer.

thanks!

Servers by jDrones