Sonar cannot be checked to enable in Mission Planner?

Trying to install sonar on my hexacopter and Mission Planner(1.3.19) will not allow me to check the box to enable sonar.

I have V3.2.1 in hexacopter and have made the parameter changes in the full parameter list (RNG…)

I can hear the Maxbotix sonar clicking but Mission PLanner will not allow me to check the box to enable the sonar. It’s as if the function is disabled. Any ideas?


Which Maxbotic Sonar are you using, analog or I2C?

It is the XL-MaxSonar-EZ with the MB1240. Analog voltage output.


Have you checked the Status tab on the Flight Data page to see if “sonarrange” is displaying data from the sonar module?
Also is this on an APM or a PixHawk?

Yes I have. Both sonar readings are 0. From what I understand the Mission PLanner software does no hardware check, so no matter what if the option is available it should allow me to check the box whether I have one hooked up or not. The sonar seems to be working fine as I can hear it click…click…click.

Then “enable” label is darkened so as to imply the option is not available, and no drop down box data is visible.


APM 2.6

Must reboot after changes. Fixed it works great

I have made all the changes as per range find in the advanced params , the sonar is working and can be monitored, but the quad is not using it to control height . the sonar enable panel in mission planner is still inactive .
Has this been remover from the firmware.? Running ac 321, last stable release. f/c apm 2.6.
How did you enable yours, ?

I also can’t enable the Sonar. The check box is disabled.
What did you do to solve it? To reboot is only to unplug the controller from the computer and plug it in again?