Some times arms sometimes disarms "No RC Receiver" - Solved

Using ardu copter v3.2.1 and latest beta MP.

I have flown this this hardware before. I have crashed also. Today I was able to arm and run the motors for a minute or so. Shut 'er down and tried again but it disarmed and said No RC receiver which is interesting because I just triggered the arming with the transmitter talking to the receiver. It appears to be intermittent. Other discussions of of No RC receiver never seem to end with a solution.

Any ideas? Questions?

I would turn up logging and try to arm again so we get a log. Then let’s take a look at it. It could be the throttle PWM value is or maybe one of the other outputs is going bad. Low PWM on a input line will make it think you have no RC.


Do I have to enable logs? Is there a tutorial on using them. You may be on to something on the throttle setting. I think you are talking about data flash logs. I should delete some of my old ones for starters.

Thanks for your offer to guide me in the interpretation.

Here’s a link to the log bit mask. You should set nearlyall as this will record the RCIN which will tell us how your receiver is doing. The default for APM2 is 830 (default).

You need to use Mission Planner and download logs from the first menu (HUD).


Don’t see a link. But here are the logs I have from tonight’s event. A little different in that it armed and ran the motors for awhile. When I lowered the throttle I got the No RC receiver message and then the motors revved up and everything froze. Had to power down and reboot everything. Eventually got the attached files downloaded.

I have a bunch of .bin, .log, .kmz etc but how to I get them to you? This forum only allows pictures and txt.

You have to use google drive or one drive. Most people have them I guess. Post a link to the share should do it.

Only need the .bin file. It may not show much since the default logging is set to low to be of value.


OK. I got a “clean” run this morning where the quad armed ok and ran for 30 seconds or so. Then I lowered the throttle and got the No RC message. No motor revs or freeze. I downloaded the logs and put them on One Drive:!3877&authkey=!AAuxEuQQ4_dzlUc&ithint=folder%2Crlog

I have learned more overnight about logs which I have used before but not for debugging. I will continue to study.

My log bitmask is 894 currently.

Thanks for looking at this.

From the logs it looks like the RC input is fine. The flight controller just stops. Did not see the input go to zero. May have to set it to log while disarmed to see what happens. No error messages in the log.


Busy today but I will do the Nearly all + disarmed by tomorrow am.

Thanks for the quick feedback.

I seem to be going backward. The system readily duplicates No RC immediately when an Arm is attempted after connection but the only logs presented are the .rlog and .tlog.!3905&authkey=!AGRvGdHQ1B1PQjg&ithint=folder%2Ctlog

I have also been having trouble with Mission Planner Terminal. Once I connect it starts to login but then says calibrating intermixed with lots of unusual characters that go on forever. Same thing if I try to list the log files from Terminal “Log Download” - just gibberish.

Radio? APM Board???

You can download the logs from the HUD screen. In the lower menu to the right there is a Data Flash log menu and a button for download data flash logs. This is simpler than using the Terminal screen.


Yes that is what I have been doing. This last short run did not yield a .bin file. There is a message in there that there was no log because the throttle didn’t get above 20%.

But the fact that the terminal program doesn’t work may be related.

I’ll keep trying.

Due to the code size and functions that run on APM2 they have a parameter to enable the CLI. Make sure that is set to on or the terminal will not work. You just get the Mavlink gibberish.


Couldn’t find the CLI parameter. But I did discover that I had managed to down load a Version 3.3+ but I have an APM 2.5. So I downloaded V2.3.1.5. Now Terminal works. But no change to the No RC receiver problem.

I am unable to turn on the Log while disarmed bit. When I try to set LogBITmask it accepts the large number but when I disconnect and connect and read it again its has been reset to 32767 - thats as large as it will take but I need to add 65536. Hmmm… Maybe my hardware is too out-of-date.

So i am not even getting any .bin files. Just .rlog and .tlog.

The No RC receiver has to be in the code with some sort of test which makes it believe there is no RC receiver digitally speaking (but I can see it right here!0.

Yes, the wiki is for the current version and not older ones. The CLI was changed to not be enabled in 3.2.1 to save processor power for new features. On the older version the CLI was always enabled.

The bitmask has changed for the logging so don’t know what it needs to be set to.

To me I would use a different RC receiver as this seems to be the issue. Otherwise you have a bad APM2 board.


Ok, I’ve been tempted to try that. I don’t have another 9 channel Orange Rx but I won’t be needing 7 & 8until I am flying and ready for autotune, etc.

Thanks for your feedback. I’ll try it today.

No change with different RX and TX.

Went back to v3.2.1 and found that it accepts 131071 as the Log_bitmask. That’s everything,


I am not getting .bin files; just rlog/tlog. Documentation says for 'Copter logging doesn’t start until armed. Not much good since I added “log while disarmed”.

I am continuing to search the code in github for 'Copter.

Whereto now?

tlogs and tlogs are on the computer. .bin files are on the copter and have to be downloaded. There is an option to download the logs next to replaying the tlogs on the HUD screen.


1 Like

Ok. I have noticed that t,rlogs are first created in folder logs and aren’t shared during a connection. Then they move to Quadcopter where they can be downloaded. Since No RC Receiver occurs immediately on arming and even a few times at connection, .bin file is not generated unless the arm process happens. Which has happened but only once yesterday. I didn’t save it as it was quite long and I couldn’t see anything. I tried to capture a shorter one but haven’t succeeded.

“On Plane and Rover dataflash logs are created soon after start-up. On Copter they are created after you first arm the copter. This topic explains how to configure and access Dataflash logs.”

Stepping back:

  1. This system (same apm/receiver/transmitter). Once flew all including Auto mission.
  2. Last time flying it suffered a serious crash and was rebuilt. The problem has existed since then - no flights.
  3. Others having No RC Receiver have not reported an explanation for the meaning behind the message. One also reported that his attempts to find a reference to it in github failed. Also true for me so far but… I’m still looking.
  4. “Fixes” reported are re-flashed FC and or re downloaded MP. I haven’t tried the latter.
  5. Conclude I should get another board.

I have HK mini and micro boards but I would like the same form factor. The others are destined for other projects not yet ready to fly.

I’ll report back when I make more progress. If a new board fixes that will be reported, too.

Aha! It appears to be fixed. I decided to search github for MP. There I found references to “No RC Receiver” and “NoRCReceiver”. The failsafe for throttle looks for channel 3 of less than 975 to declare failsafe. I had set mine at absolute minimum which was 968 so my normal stick travel got into failsafe for throttle. If you bias the minimum throttle channel 3 up to 1000 before radio calibration and then turn your transmitter off the throttle channel goes to 962 - radio failure! I would preferred a message like “Throttle failsafe reached” or some such.

Thanks for guiding me to logs, etc.