Some questions on setting up Arduplane


I am in the process of setting up a wing. Manual and Acro (with adjusted roll/pitch rates) works well. A Autotune also worked fine and about doubled the PID’s from the very conservative initial setting.

I hope you can answer some of my questions, mainly to helo me better understand.

  1. There is a parameter ACRO_LOCKING. My understanding is if enabled it will hold the attitude and will not level. What does it do if not enabled? Level?

  2. Is there a mode that is acting like acro but limits bank and pitch angle? I know there is FBWx but these seem to be self leveling modes

  3. If I switch to Loiter (same with Circle) on the bench the servos seems to behave erratic. I’d expect servo movement to one position as the system tries to change attitude (turn or so) and remain there as the plane is not reacting with a change in attitude on the bench. Instead the servos seem to randomly change throw and direction. Correct?

  4. I noticed I have low pitch authorithy in Autotune which I guess is using FBWA. Is this due to the low pitch angle defaults (+20, -25)? What are reasonable values for pitch and roll limits?


FYI: I am a bit of a beginner myself (with about two months experience with ArduPlane).

  1. no help
  2. FBWB is self-leveling. But FBWA is NOT self-leveling. I like TRAINING mode, as the plane responds just like an RC plane but won’t allow it to roll or pitch past the limits.
  3. I would not worry about this too much. my experience is that is is hard to do much bench testing with auto-pilots. My servos also do weird things on the bench.
  4. Autotune starts out with very little servo authority ( at least on my Sig Kadet Senior). When I first flew in autotune mode, I could barely execute a turn in one direction and had to turn the other way. Eventually (after many minutes - at least five minutes I think), the plane begins to respond more. In my case, the autotune changed the PID parameters by quite a bit. As I recall, it doubled the “P” parameter for pitch and roll. I set my roll limit at 45 degrees and pitch limits at 25 or 30 degrees.

Thanks for your reply

  1. Still interested in finding out about this
  2. Reading the wiki and having flown FBWA I think it is self-leveling. In FBWA the stick deflection controls the roll/pitch angles whereas in ACRO it controls roll/pitch rates. Stick neutral in FBWA asks for 0 degree roll/pitch angle. Try it. Push aileron stick to full. The plane will bank to the roll limit. Release the stick to neutral the plan will level. I’d like to have a roll/pitch limited acro mode, e.g. rate mode with angle limits. As far as I understood FBWB acts the same as FBWA. It just adds altitude control.
  3. You were right. I tried Loiter mode today and it worked fine.
  4. Autotune worked the same for me. After increasing roll limit to 50 and pitch to 25/30 control authority in FBWA was good.


  1. I will check FWBA mode next time I’m flying to see if it is in fact doing wing-leveling. You are probably right and my memory is just not right. The plane i am flying (Sig Kadet senior - a high wing RC trainer with dihedral - is inherently wing-leveling so I may just be confused). Good luck.


I’d recommend following the instructions in the autotune guide before altering your pitch and roll angles, as long as you are able to maintain control with the heavily dampened PID values initially. Altering the pitch and roll angles to increase control in autotune mode can end up giving the false impression of a tuned airframe.

I did the same thing as you on the first fixed wing I set up. It flies fine, but there are small details that I couldn’t figure out until my 2nd build, such as trying to dial in the xtrack error.

As for the ACRO parameter, I am guessing at this and not speaking from experience, as all of mine are set up for auto flight for surveys. I’m guessing that parameter is intended to be used with a flight mode switch to acro mode, and not manually changed. I won’t quote the acro mode text as it sounds like you’ve read through the flight modes, but I did want to add one tidbit from personal experience.
-Make sure to pay attention to the way altitude and throttle works in FBW-B mode, especially if you have a geofence enabled. I might have heard a story about a friend (definitely not me) that crashed my…er, his plane into a tree while trying to land in FBW-B mode due to inexperience.