SOLVED! Wrong semicolon in geotagged images for survey

Hi all,
I managed to geotag images from a .log file, to use them in Pix4D photogrammetry software.

It apparently succeed, but Pix4D does not recognize the geotag as there is a wrong positionning of the semicolon in the cordinates.

The right format should be “xx;xx;”, and I have" xxxxxxxxxx;0;0"

Any idea of what could be setted to achieve a good result?
I have a good kml result in google earth, the numbers are the good ones but the semicolon and dot are not positionned at the right place…

Thank you,
Julien from Corvus

what version of MP are you running?

Hi Michael,
I’m usine the


Is this from a tlog?

Yes, I downloaded the log with winscp. I had to rename it **.tlog, don’t remember the original suffix…

MP show displays right flight path, googleearth too.
Thank you,

yes, there is an error in formatting of the lat/long data in the tlog. Why are you using tlogs to georeference your images? Have you tried using mission planner’s georeference tool? It works with log files with properely formatted data.

If you need to tlog data, you’ll have to manually reformat the data in excel or some other spreadsheet. It’s tedious and not much fun.

Thanks for the help,

I use tlogs because I can’t manage to get the logs from the tablet I use for terrain missions.

Is there a way to have the log directly from solo, or should I use my laptop to fly, and then use the good logs?


Yes, you can dowload files directly from the pixhawk in the solo.

Check out this link,

I followed that procedure, but when i opened the log file in winscp, I only found 1 .log, wich was a previous flight, not the last one. I’ll give another try as soon as the weather permit it and give you a feedback.

thank you for your help,


After a new try, from the beginning, everything works fine!
I had been lost by a topic (not on this forum… sorry…:wink: ) saying the better way to get logs from solo was Winscp… But it works as well as my DIY pixhawk aircrafts, with missionplanner and “download dataflash via mavlink”

It was in fact so simple…

Thank you for your help!!

Happy to help. Glad you found a solution that works for you.