[SOLVED] Turn Radius/Bank Angle in FBWA, Loiter and Auto Modes

Hoping for some steer here: I seem to be hitting a limit in the maximum commanded bank angle/turn radius and trying to understand what’s going on. I am running 3.8.3 in a Discovery/Sensei trainer and I have done lot’s of autotune, etc. On my most recent outing to the flying field, I was trying to set a smaller WP_LOITER_RAD to keep the aircraft withing the bounds of the field. However, even with a setting of 30m, the aircraft is circling with a radius of around 90m.

I also noticed that in FBWA mode, the turns are very wide. I have set LIM_ROLL_CD to 6,000 (60 degrees) but the aircraft seems to be doing much shallower turns.

Any thoughts?

Related question: does WP_RADIUS over-ride WP_LOITER_RAD? In other words, if the latter is higher (say 90m), would that determine the Loiter radius I am seeing, even though the former is much lower?


1 Like

An autopilot log file would be most helpful. Are you at a high altitude? By default the loiter radius of the aircraft is scaled with the altitude the aircraft is flying at, to reduce stress to the airframe.

I agree that logs would be the most useful. In my experience it has been due to the stall prevention code so you may need to increase airspeed or reduce ARSPD_FBW_MIN. That’s only an initial guess though.

Thanks for your replies, guys. @WickedShell, regarding elevation/altitude, I can confirm the flying location is only just above sea level, so we can rule that out.

I have uploaded a bin file to here: https://www.dropbox.com/s/8k8v6rnc9ho005j/2018-05-06%2013-27-15%20(Discovery).bin?dl=0

Appreciate any thoughts/advice.


The NAVL1_Period set at 15 for your plane is quite conservative try 12 or even 10 after you have done some tuning.

One of your sharpest turns while in Stabilize mode was this one

But your Rc Input was quite small so it might have been sharper with more stick command.

My suggestion is to try while in FBWA mode and at least 11 m/s speed to give full stick turn command
and see what is the turn radius you obtain.


Hi Jacques,

Try increasing the MIXING_GAIN. The default is 0.5 but I typically use 0.8.


I did some more tests yesterday, with NAVL1_PERIOD reduced down to 10, but this does not seem to have made any difference. The bank angle in FBWA, Loiter modes and Auto modes is very shallow - I would say less than 25 degrees, despite 60 degrees for LIM_ROLL_CD. The loiter circles are about 60m in radius, despite WP_LOITER_RAD being set to 30m. I’m really stumped with this!

I have uploaded the log here:

Parameters are uploaded here:

Really appreciate any help here.


Hi Nathan, just to confirm that ARSPD_FBW_MIN and TRIM_ARSPD (10 and 12m/s respectively) are fairly high for this lightly loaded aircraft, well above the stall point.

Hi Greg, I’ll try that next time, although I really think there is some mysterious limitation in the max bank angle!

Problem solved, with input from Dr Tridge himself, on the Facebook forum!

It was a combination of 2 things:
Firstly, long tubes for airspeed sensor, which are giving me unreliable readings (ARSPD_RATIO is 1.06).
Secondly, STALL_PREVENTION is enabled, and this will be even more conservative due to unreliable airspeed readings.

Philip Rowse said I can go to 45cm on I2C cables (if they are clear of other cables, etc), so I will locate the airspeed sensor closer to the pitot to allow me to shorten the tubes.


1 Like