[Solved] Telemetry to Radiomaster TX16S from Frisky X8R receiver

I’ve been following the Wiki info on how to get extended telemetry displaying on my Radiometer TX16S from a X8R receiver connected to a Cube Orange. I notice there are a few other posts here on the topic and I’ve had a try of all the suggestions I could find but I’m still not getting the telemetry feed as expected.

I have pin 1,2 and six of Telem2 port on the Orange Cube connected to the Smart port on the X8R and have put a 10k resistor across the signal and ground. I’ve set the protocol to 10 and the options to 7.

Interestingly enough when I use the Telemetry page on the Radiometer to ‘Scan for new sensors’, it finds and displays one additional sensor, a GPS with hardware ID 251. But that’s it. I’ve watched videos that show a long list of sensor info being displayed at this point.

Any idea why I’m only getting one sensor displayed and what else I can try to correct this issue?

Same problem with me too

Hi, this means everything is working properly for the use case of yaapu telemetry.
More details can be found here.

If you are interested in native Frsky S-PORT telemetry without running the yaapu script on the radio transmitter you should set the parameter: SERIAL#_PROTOCOL = 4. More details can be found in the full parameter list

Now you can discover all telemetry sensors in the telemetry screen.

Hope this helps.

I’m following along with this Painless 360 video. At 2.45 min in he states that step one is to get the sensor info displaying. I’m not seeing that on my radio.

Looks like the video I was following was wrong about the sensors displaying. As you said, the configuration is working. I went ahead an installed the yappu script and it’s displaying as expected.


1 Like