**Solved** Servos lock up to max when all servos are used. Zener diode and capacitors on servo rail?

I am trying to configure my Bix3 with a pixhawk, and I have found a very strange problem.
I have 4x 9gram metal gear servos for ailerons, rudder and elevator, and 2x 9g plastic gear serovs for flaps.

Problem is that if all these servos are connected to the Pixhawk and I switch into FBWA, alle servos lock up and go start pulling all that they can in one direction. If I disconnect the ailerons and connect the flaps servos to the aileron channel everything works great. If I disconnect the rudder and elevator, the flaps and ailerons work great. In conclusion, I have found that by having 4x metal gear servos and 2x plastic gear servos the issue is provoked. By connecting only one of the aileron servos (either one, doesn’t matter), there is no problem. By changing one of the aileron servos to a plastic gear servo, the problem is reduced. By that I mean that the servos don’t lock up permanently, just for a second or two.

When the servos do lock up, I can free them back to normal by unplugging the aileron servos, i.e. reducing the number of servos connected to the Pixhawk.

I have found that the FBWA nature of using all the servos at the same time is the problem causer, in MANUAL I can operate all the servos just fine. A little strange, but in MANUAL I can use all the servos simultaneously, but if I but both sticks of the radio to a corner and release them so that they bounce back to center really quick the problem occurs and the servos lock up to max again.

The metal gear servos are 9g Turnigy TGY-50090M and the plastic gear servos are 9g HobbyKing HXT900. The servos rail is powered by a Pololu 5v 2.5A step-down regulator (D245V22F4), which is connected directly to the output of a 3DR power module in parallel with the ESC. Link to the power module is attached below.

My conclusion is that the system is somehow overloaded or influenced in some way by the metal gear servos. As i said, by using plastic gear servos on the ailerons there is no problem.

After searching the internet for servo behaviour, i see that the servos can cause voltage spikes. Maybe the voltage across the servo rail is influence by the servos in such a way that the servos start to misbehave.


I found that in the documentation for backup power it is recommended to mount a zener diode and capacitor to the servo rail (I find it weird that this is not mentioned in the servo chapter in the documentation, which is the one I have followed).

I have now installed a IN5339 5.6V 5W zener diode and a 1000uF 25V capacitor, and can report that the issue of the locking servos are almost gone. By that I mean that FBWA functions properly unless the plane is rocked back and forth in pitch and roll in a really agressive manner. I can still provoke the problem in MANUAL by applying maximum elevator, ailerons and rudder, and then realising them all suddenly.

I tried a 470uF capacitor, but that just helped a little, much worse than the 1000uF.

I have noticed that most BECs come with a capacitor installed, the Pololu step-down regulator I am using does not have a built-in capacitor. Would it therefor be okay for me to use a larger capacitor on the pixhawk? Maybe 2000uF?

Have thought about it some more, I realize that the need for such a big capacitor maybe indicates that I am having a problem with voltage drops. Could it be that my 2.5A power supply isn’t large enough to power 4 servos while testing? I have not been able to figure out the amp draw on 9 gram servos.

In total I need to power 8 servos (ailerons, flaps, rudder, elevator, pan and tilt). I read somewhere on rcgroups that it would be safe to assume a max draw of 250mA per servo, giving a total of 2A. But again, this estimate is not verified.

I have ordered a 9A 5V switching regulator from Pololu, hoping that will solve my problem.
Since the current diagnosis is that this is a hardware problem that is related to the power on the servo rail, I suggest that this topic is moved to the “Hardware” section of the forum. I this something I can do myself or can a moderator be so kind to move it for me?

The problem was solved by replacing the 2.5A power supply with the 9A power supply.

As stated in the previous post, this thread should be moved to the “Hardware” section.

Thanks for describing problem and way of solving it. Looks like I stuck with same problem - playing with couple of radiosticks causes all my servos sticking dead while controller seems working through usb connection.

will check and update if heavier ESC fixes issue