[SOLVED] RC6 m8n "GPS 1 failing configuration checks"


I’m getting the following prearm errors with Copter 3.4 RC6:
[MAV 001:1] PreArm: GPS 1 failing configuration checks
[MAV 001:1] GPS 1: u-blox raw rate configuration 0x100

The GPS has 3D fix, good HDOP and sats count, which are all shown correctly on APM Planner.

System configuration:
TBS Discovery quad, 3DR Pixhawk, uBlox Neo M8N GPS.

The copter flew great with 3.3.3, no GPS errors whatsoever. I’ve upgraded to 3.4 to use the new MAV GPS mode with Raspberry Pi companion computer for my project, but I didn’t enable it yet, I just want to get it flying first.

Did anyone fly 3.4 successfully with m8n?


PS My parameter file:
copter 3.4rc6.param (11.5 KB)

You have GPS_RAW_DATA turned on but, as far as I know, the M8N doesn’t support it. So put GPS_RAW_DATA back to 0 and that problem should go away.

As @OXINARF indicated RAW_DATA isn’t valid on a M8N, you need a Timing u-blox to enable it. If you look at the messages tab on the MP when you fail to arm you should see a more detailed message which tells you what part of the GPS configuration that failed.

Thanks for the reply! I’ll try @OXINARF’s solution on Monday and report back. Meanwhile I found out that the configuration check has been added recently (in RC6), so I just commented it out temporarily and had a couple of flights without crashes so far.
I cannot comment on flight quality yet as I changed a lot of parts on the quad and it’s 200g heavier now, so I need to do autotune again with the new firmware.

Thanks @OXINARF and @WickedShell, problem solved!

There is a solved button that you can use instead of changing of title. It is hidden behind the three dots. I marked my post as the solution, feel free to change it to another post if you want.