Solved: Radio failsafe, receiver off - not working

Hello.
A strange thing happened to me.
I have a companion computer that generates PPM signal and is connected tu cube orange RC IN.
It works good, but today i noticed a problem. When i turn the companion computer off, The Cube still reads PPM. Looks like it reads the last value when it was connected, but wont drop to zero. I wanted to set the radio failsafe, but like this, its not possible. Has anyone encountered the same problem?

What FW version? What HW?

Sorry.
AC 4.0.6. HW Cube orange
I dont even know if it is bug, or some feature.
But tried it again just few minutes ago. and when i turn off the companion computer that generates PPM signall, in mission planner i still see last PPM values.
Just for the record. i am sure that companion computer is not alive, and ppm output checked with osciloscope

looks like a bug to me. please report it on github

It’s most likely that it’s not a bug. I guess what you’re expecting is that an RC failsafe will trigger? I think it will trigger if the FS_THR_ENABLE parameter is set. If you have an onboard log we can check.

Sorry to play tug-of-war with other devs but let’s investigate it here before we create an issue.

Hello. so I ran couple more tests and you are right it is propably not a bug.
When i turned off the Companion computer today, it still logs last value, BUT it triggers Radio failsafe as it should. What happened yesterday as i discovered today was that my companion computer froze “partially” it didnt react to any input, but it kept generating ppm signal, thats why failsafe wasnt triggered.
So the mystery is SOLVED!

1 Like

Great!

I have mention that passing PPM signals in is about the worst way to
control ArduPilot from a CC; consider using the rather rich set of mavlink
messages to control the vehicle.