[SOLVED] PreArm: RC Roll not configured

Despite multiple calibrations will not arm

I recently had a similar problem in pitch instead of roll. Try manually adjusting the roll channel min and max PWM limits by 1us (or any amount for that matter) in the full parameters list, write these settings, and then change them back to your original calibrated values. It seems that it’s looking for a change in these values on each channel to verify an adequate radio calibration was performed and I guess either the logic fails occasionally or the calibrated values are identical to the default values and no change is detected. This seemed to fix it for me though.

1 Like

Ok that worked! I noticed that I had to change the mins away from the default I’m not sure if its my radio or where that seems to have a deadband set at the min thus defaulting to the “default” min and thus not accepting it.
So for those of you that have this issue after you calibrate if you see EITHER the min or max at the default values it will not accept it even if the other value is non-default as seen below:

Thanks Garrett!

thank you !i have this error too.