[Solved] Plane 3.8 upgrade problem or user error

Hi All,

My first post!

I upgraded last night to 3.8, after a reboot, my vtail setup had changed, I’ve since sorted this with a very comprehensive explanation document in plane.

I have since noticed another problem which I cannot seem to fathom out, when I connect the power supply, the pixhawk boots up perfectly, then I expect no output to the servos until the safety switch is pressed, when I checked to make sure I had no signal to the servos by moving my transmitter sticks the right Vtail moved up and down.The safety switch is flashing to show a safe state, nothing else moves or operates, the throttle is safe, just the right hand Vtail moves. When I press the safety switch the light goes solid red and everything operates as normal and I am able to arm the motor.

Many thanks for you help

hi Richard, can you post a copy of your parameters? I’d like to try to reproduce this.

As requestedTalon Parameters.param (14.0 KB)

Hi Tridge
Anything found on this problem

Dr Tridge

I have solved this problem
the BRD_SAFETY_MASK was set to 2 which allowed channel 2 elevator of the v tail to operate while the safety switch was flashing.

Not really sure if this came across with the upgrade or when I uploaded the old parameters, I probably think it was operator error


thanks for letting me know, and my apologies for not looking into this sooner

Cheers Tridge, I understand how busy you are